Ask Your Question
0

Zotero footnotes: titles lack italics

asked 2017-11-26 15:36:01 +0200

brokenindexfinger gravatar image

updated 2017-11-26 16:12:11 +0200

I've been using the zotero plugin for LO for years. Returned to write final papers and now see that footnotes do not have italics for book titles. I've updated JDK, reinstalled and updated LO, reinstalled the zotero plugin for LO, updated Zotero, nothing seems to fix it. Zotero's documentation says that LO governs the formatting of the footnotes. And when I test the formatting in Zotero's formatting editor, the italics are there and correct.

  • LibreOffice Version: 5.3.6.1
  • Zotero Standalone: 5.0.28
  • Chicago Manual of Style 17th Edition (note)

I've tried to modify the footnote style, but I don't see how I can edit the presence of italics in a portion of the footnote using that dialog. I can change the font size and spacing etc of the entire footnote, but not the appearance of an individual section of the footnote... Anyone run into this? As a workaround, it is possible to manually change each footnote to have italics where required but this is clearly a regression from prior functionality.

edit retag flag offensive close merge delete

Comments

floris v gravatar imagefloris v ( 2017-11-26 17:08:15 +0200 )edit

Yeah that's me.

brokenindexfinger gravatar imagebrokenindexfinger ( 2017-11-26 17:24:02 +0200 )edit

That's called cross posting and people tend to hate it a lot because it means more work - you get a discussion dealing with the same points on two places instead of one, and one of the topics may still get new posts when the problem has been solved in the other. No hard feelings to you, but please remember to post links to other places where you ask the same question.

floris v gravatar imagefloris v ( 2017-11-26 17:30:24 +0200 )edit

Thanks for the lecture. Given that this may be a LibreOffice issue, or it may be a Zotero issue, I decided to post once in both places. I did my due diligence and did a great deal of troubleshooting before posting. I have also provided platform information. This question is also different from the other. And until one or the other has a solution, well, it doesn't make much sense to provide a link. But I guess every platform needs someone to police it.

brokenindexfinger gravatar imagebrokenindexfinger ( 2017-11-26 17:52:30 +0200 )edit

I beg your pardon? I pointed this out in a friendly way and you manage to mistake it for flaming?

floris v gravatar imagefloris v ( 2017-11-26 18:37:28 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-11-27 17:55:53 +0200

brokenindexfinger gravatar image

This was a Zotero bug. Installing 5.0.28-beta.2+824114907 and resetting the style in the LO Zotero plugin document preferences fixed the issue.

edit flag offensive delete link more
0

answered 2017-11-26 17:33:55 +0200

floris v gravatar image

You may have to file a bug report at the LibreOffice bug tracker: https://bugs.documentfoundation.org/

Maybe the developers changed the import filter for the zotero content so that the codes for italics are no longer taken into account.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-26 15:36:01 +0200

Seen: 57 times

Last updated: Nov 27 '17