Ask Your Question
0

PDF Export Takes on Template Name in PDF Tab

asked 2017-11-28 01:20:07 +0100

LMark gravatar image

If I create a doc from a template, when I export it to pdf, it takes on the template name instead of the filename. That is, when I open the exported pdf in a pdf viewer, I see the template name in the tab. I would expect to see the actual document name there. Do we have a setting for this?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-11-28 06:27:22 +0100

KH gravatar image

updated 2017-11-28 06:40:54 +0100

This is something that bothers me as well. As of version 5.4, the "Title" property of the template file is set automatically when you use the Save as Template... command. If you do not erase it, it will be copied to every document created from that template. The value in the "Title" property of the document itself is used when exporting to PDF.

So, you will need to erase the "Title" property from the template. Right click > Edit from the template manager, then navigate to the "Description" tab of the "Properties" dialog (File > Properties > Description). You will also need to do this for any documents you have already created from the template.

Of course, you could write the actual document name in this field. This can make the result look a bit more professional, especially if the filename is not exactly the same as the title. If you don't, the filename of the exported PDF ("something.pdf") will be seen by default. At least, that's what I get when opening PDFs in Okular on KDE Plasma 5.

edit flag offensive delete link more

Comments

Okay. That's helpful. Thanks! LMark

LMark gravatar imageLMark ( 2017-11-28 08:32:25 +0100 )edit

Good to hear. In that case, you should upvote and accept this answer.

KH gravatar imageKH ( 2017-11-29 05:10:19 +0100 )edit

Hmm. Apparently I do not have enough points to upvote. How do I show that the answer has been accepted? Sorry to be so ignorant. L

LMark gravatar imageLMark ( 2017-11-29 15:03:45 +0100 )edit

Click the check mark under the downvote arrow :)

KH gravatar imageKH ( 2017-11-30 10:00:42 +0100 )edit
0

answered 2018-01-24 03:22:26 +0100

Happy User gravatar image

It works! Thank you very much.

I can't upvote as this is my first visit, but I am really happy.

Thanks!

edit flag offensive delete link more

Comments

Great to hear! FYI since you're new: things like this should be a comment on the relevant answer.

KH gravatar imageKH ( 2018-01-24 10:27:22 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-28 01:20:07 +0100

Seen: 333 times

Last updated: Jan 24 '18