Ask Your Question
0

Shortcut keys: Insert current time results in date and time being inserted, rather than just time.

asked 2017-12-05 15:23:30 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

My platform is Trisquel Mini 7.0 with amd64 architechure, using libreoffice Version: 4.2.8.2.

I would like to set up a shortcut key to insert the current time, with no preceeding date. Unfortunately I can't get this to work currently like I could 6 months ago.

The only difference between now and before is that I am currently on an amd64 platform, and before I was on a 32-bit system.

Attempt 01: Menu Bar >> Tools >> Customize >> Keyboard I configure the lower part of the dialog box first:

1) Functions:
    a) Category
        1> Insert

    b) Functions
        1> Insert Current Time

I then go above and select the preferred key combination:

2) Shortcut Keys: 
    a) "Ctrl + Shift + ;"  
    b) Fill in "Calc: circle (not libreoffice circle")

I then hit "modify". From now on I can see the "Ctrl + Shift + ;" under the Keys column.

I then restart libreoffice. I utilze this key combination, and it not only inserts out the current time, but also preceeding this is the date.

{fail}

Again, I would like to set up a shortcut key to insert the current time, with no preceeding date.

edit retag flag offensive close merge delete

Comments

Does this behavior occur if a new spreadsheet is created? Note: It is not recommended to check the community wiki checkbox when asking questions.

Jim K gravatar imageJim K ( 2017-12-05 18:18:29 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-12-05 18:17:41 +0200

Jim K gravatar image

This sounds like a number formatting issue. Select the cell and go to Format -> Cells or press Ctrl+1. Choose a time format that does not include the date and press OK.

Now go to Insert -> Time or press Ctrl+Shift+;.

edit flag offensive delete link more

Comments

Quoting @ Jim K: "This sounds like a number formatting issue."
How? For me the command is working as expected, and the actual content the respective cell gets filled with does not depend on the previously chosen 'Numbers' format of the cell. The direct format code HH:MM:SS is superposed actively by the command. The value also contains a centisecond part.
A different behaviour should either be a bug depending on the hosting system or due to user profile corruption, imo.

Lupp gravatar imageLupp ( 2017-12-05 20:02:38 +0200 )edit

To be clear: The inserted value insn't just formatted to suppress the integer (date) part, but actually is LT (less than) 1 (one day) as if obtained by the expression Now()-Int(Now) and rounded or truncated to a resolution of 1/100 s..

Lupp gravatar imageLupp ( 2017-12-05 20:10:19 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-05 15:23:30 +0200

Seen: 2,128 times

Last updated: Dec 05 '17