Ask Your Question
0

base list box dropdown breaks when any formatting added

asked 2017-12-06 14:52:02 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I've managed to use the list box wizard to add a list box with dropdown onto a form, and it works fine. However whenever I change the formatting, e.g. set the background to gray, make it look 3d the dropdown functionality stops working. It still shows the correct field. Here's it working fine when I don't make any formatting adjustments:

image description

If I make any formatting adjustments it stops providing a drop down list, and if I then remove those changes it still doesn't work.

Any ideas?

p.s. I'm on OSX 10.12.6 (Sierra) and 5.3.6.1 of LIbreOffice

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-12-06 15:42:50 +0100

Ratslinger gravatar image

Hello,

The most likely problem is that you are doing something wrong. If you change a property in any control and then use the mouse wheel to try to scroll down the list, it actually changes the property value. If you don't see this, you inadvertently have changed a property value and think the system isn't working.

I have used this control hundreds of times without this type of problem. In fact I just tested again using the wizard, changed text positioning, colors and more without a problem. This on a Linux Mint 18.3 system using LO v5.4.3.2. I have also never heard this happening on any other system.

I'd ask you to post a sample (probably the only way to verify what is happening) but unfortunately you posted as Wiki - not recommended as it helps no one. You also failed to mention your OS and what version of LO you are using.

edit flag offensive delete link more

Comments

Make certain the Dropdown setting in properties for the list box is set to Yes.

Ratslinger gravatar imageRatslinger ( 2017-12-07 00:22:52 +0100 )edit

Thanks for the input. Here's the settings on a working dropdown:

tansaku gravatar imagetansaku ( 2017-12-07 11:42:44 +0100 )edit

I change it to 3d look

tansaku gravatar imagetansaku ( 2017-12-07 11:43:24 +0100 )edit

and the dropdown stops working:

tansaku gravatar imagetansaku ( 2017-12-07 11:44:06 +0100 )edit

Have seen other 3D errors in past (ie: checkBox ) but not this one. Please file as bug here.

Ratslinger gravatar imageRatslinger ( 2017-12-07 16:21:17 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-06 14:52:02 +0100

Seen: 24 times

Last updated: Dec 07