Ask Your Question
0

Can I turn off automatic language selection? [closed]

asked 2017-12-06 15:26:48 +0100

pincopallino gravatar image

Greetings,

I have more than one keyboard layout installed because I need to write in different languages. I frequently switch layout, depending on the application (e.g. a text in English and an email in French...) Every time I change keyboard layout, the spell checker in LO also automatically changes accordingly. Which is quite annoying - the fact of having a different layout active does not mean that the text I am typing is not in English! Is there any way to prevent LO from automatically adjusting the spell checker to the keyboard layout?

Thanks in advance for your suggestions.

[using LO 5.4.32 (x64) under Win10 version 1709].

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by pincopallino
close date 2017-12-07 15:05:25.138285

2 Answers

Sort by » oldest newest most voted
0

answered 2017-12-07 11:21:35 +0100

Mike Kaganski gravatar image

Please check Ignore system input language at Options-Language Settings-Languages

edit flag offensive delete link more

Comments

This seems to be the solution to my problem. Thank you so much for the hint!

pincopallino gravatar imagepincopallino ( 2017-12-07 15:04:33 +0100 )edit
0

answered 2017-12-06 22:27:57 +0100

ajlittoz gravatar image

Text language is an attribute that can be set in (paragraph and character) styles, Font tab where you'll find a drop-down menu.

I assume your document has a principal language and quotations or inserts in other languages. Design then your main Text Body (Corps de Texte) to target the principal language and make linked paragraph styles e.g. Text Body de, Text Body it, ...) whose only difference is the language. Do the same for other paragraph styles.

For foreign "word" insertion inside a paragraph, design a character attribute forcing the language to the desired one.

Spell checker will use the language defined by the style(s) and will correctly flag invalid words in the designated language (provided the dictionaries have been installed).

Note: you can set language to None to cite computer source (or other "neutral" excerpts) to disable locally spell checking.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Thank you for your answer, but this is not what I have asked. I am not inserting foreign words, I am sometimes using a different keyboard layout to type English text. My style definition has "English (UK)" as language. When I have another keyboard layout active (e.g. French), then Writer automatically assumes that I am typing in that language. Instead, I am still typing in English, only ,the keyboard layout is different. How can I stop it from making assumptions, no matter the keyboard layout?

pincopallino gravatar imagepincopallino ( 2017-12-07 09:04:06 +0100 )edit

Is there a difference in your settings (language preferences) when you switch from keyboard-layout?

PèreOrval gravatar imagePèreOrval ( 2017-12-07 10:07:01 +0100 )edit

Then it appears to be a Windows issue and I can't help you ("Linux inside" here!) because this doesn't happen on my computer.

ajlittoz gravatar imageajlittoz ( 2017-12-07 10:10:48 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2017-12-06 15:26:48 +0100

Seen: 34 times

Last updated: Dec 07