Ask Your Question
0

Writer has changed my page layout

asked 2017-12-14 16:23:42 +0200

peterfreeth gravatar image

updated 2017-12-14 16:24:31 +0200

I created a Writer ODT file for a book back in 2014, produced a PDF, that went off to print, all good.

Today, I created a PDF for a new version of the book. The page layout is different to the original, even though nothing has changed. Writer is pushing single line text onto two lines, even though the file hasn't changed, so the font size and margins are the same in both documents.

I know this because I can compare the original and new PDFs side by side. If I use GIMP to overlay one text on another, the font sizes are identical, so it seems that what Writer has changed is the margins, even though they are configured to the same sizes.

Does anyone know what's happening? It means that when I edit an old book for a new edition, I have to go through the entire book and fix all the formatting again, which can take days.

Here are the two pages side by side (hopefully)

image description

https://pasteboard.co/GYbE973.png

thanks

Peter

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-12-14 17:38:18 +0200

Kruno gravatar image

updated 2017-12-15 11:35:41 +0200

Well if you write a long document you should prepare template and save and use that template so every time you open your book LO picks up settings and decisions you baked into a template.

Opening old files without using template is causing your old document to pick up settings and formating from what seams to be default at that particular version of LibreOffice and that could be for a number of reasons, but bug fixing is the most plausible one.

Did you used styles for writing your book? If you did, all you need to do is modify that one style and everything will work as you expect it to. Even if you didn't use styles -- default page style is used, try modify that style to get it working.

What are values for margins in first document and what is the value in second. I'm guessing that you're guessing that margins are changed. Margins are logical conclusion but that might not be correct. I know there have been some text layout engine changes recently so that might cause this. I can't tell for sure as not much information is provided in your question, but fixing this should take no time at all if document is build right from scratch (styles and templates).

Next tip is to try to print new edition from an old PDF if possible. If only thing you need ti change is publication date, LibreOffice Draw might be at hand.

Think you should expect both documents and check if any of the formating actually changed and report that back. What will also be relevant is operating system and paper type and such. Much of this can be read from PDF also. Know this doesn't solve it but might give you a clue to what to do next.

Best of luck.

edit flag offensive delete link more

Comments

I kind of remember a question in AskLO (but could not recover it) about a similar phenomenon. The basic cause was the way the dimensions (like margins) were converted from inches or centimeters into internal units. With a very small convertion factor change, the internal dimensions may vary in a few units. This difference may be sufficiently small to not be visible in the dialogs when converted back to human units, but sufficiently large to cause to cause here and there word wrap ...

ajlittoz gravatar imageajlittoz ( 2017-12-15 08:59:23 +0200 )edit
1

... apparently at random. Cumulated on a long document, these word wraps result in extra pages.

You can recover from it by changing your left/right margins in page styles to e.g. 1.001 or 0.999 instead of 1.000. Experiment with the delta for best results.

ajlittoz gravatar imageajlittoz ( 2017-12-15 09:04:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-14 16:23:42 +0200

Seen: 203 times

Last updated: Dec 15 '17