Ask Your Question
1

[Solved in v4.0.2] Variable not evaluated in header [closed]

asked 2013-03-08 10:24:16 +0200

cabfred gravatar image

updated 2015-08-29 21:20:44 +0200

Alex Kemp gravatar image

Hello, I made a document in OOO. In that doc, I use a variable datePage on each page, in witch I put the date of the page. In the header, I insert the same variable so that the date appears in the header (One style, Differents dates, I couldn't find another way). I installed LibreOffice 4.0.0.3 and the behaviour is not the same : the variable is not evaluated in the header, so the date value is 0. Is that a definitive change of behaviour, or will it be implemented again in a new release, or is that just a small bug?? Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-05 11:59:10.100691

2 Answers

Sort by » oldest newest most voted
1

answered 2013-03-19 17:44:44 +0200

cabfred gravatar image

updated 2014-10-12 01:21:23 +0200

oweng gravatar image

Thanks for your advice. By the time I search in LO-bugzilla and I found two bugs about this problem : fdo#61671, the same problem was not solved. fdo#60886, same problem with a correction added to the daily-LO. I tested the daily, and it corrects the bug. So I put a few comments on 61671, marked it as duplicate and changed its status to resolved. Now I wait for next stable version of LO. I forgot to close this question, I'll try to do it now. Thanks anyway. Well, I can't close the question because of too low reputation...

edit flag offensive delete link more

Comments

Hi @cabfred,

Here's a link to fdo#60886

Your Answer points at the right bug in FDO (bonus: it's been fixed!), so I think it's fine to mark your Answer as correct. If you're not able to do that because of low karma, I'll be able to do it in a week :-)

qubit gravatar imagequbit ( 2013-03-20 09:10:54 +0200 )edit

Bug fdo#60886 was fixed for v4.0.2.

oweng gravatar imageoweng ( 2014-10-12 01:22:12 +0200 )edit

Could someone add 4.0.0.3 within the title of this question: old bug, fixed now?

Alias duel zone gravatar imageAlias duel zone ( 2014-10-12 10:50:19 +0200 )edit

LibreOffice 5.2.0.4 has got the same bug :/

rozek19 gravatar imagerozek19 ( 2016-08-29 10:49:09 +0200 )edit
0

answered 2013-03-08 19:41:46 +0200

qubit gravatar image

updated 2013-03-08 19:47:18 +0200

@cabfred,

Good question! Btw, what file format are you using? ODT? DOC?

I think the answer here is going to come down to whether OOo's behavior is the correct/only right way to interpret the spec. If there is ambiguity, then LO might not implement the spec in the same fashion.

Please file file a bug and provide a list of steps that can reproduce your problem, as well as including the file in question. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-08 10:24:16 +0200

Seen: 169 times

Last updated: Oct 26 '14