TT Northwind 'org.hsqldb.jdbcDriver' could not be loaded - Problem Repost

asked 2017-12-27 23:58:06 +0200

Ratslinger gravatar image

As there was interest in this answer, but it was deleted, here is a the answer reposted.

Original question similar to:

...download and unzipped "TT NorthWind.zip" attempting to use TT NorthWind.odb i get the following message

the driver class 'org.hsqldb.jdbcDriver' could not be loaded

Answered as:

The manner in which this .odb was created requires you to set a class path in Tools->Options->LibreOffice->Advanced for the location of the 'hsqldb.jar' file in your TT Northwind folder. With this path set the DB works immediately.

I must warn you - leaving this path setting on will cause MAJOR HEADACHES if you open any other Base file.

The actual problem is in the 'content.xml' file in the root of the .odb. There are a number of changes to make to avoid setting the class path.

Using an archive manager (zip tool) you would need to edit the content.xml file in the root of the .odb file. About 40% down is this section:

image description

The highlighted area needs to be replaced with:

db:data-source-setting-name="JavaDriverClassPath" db:data-source-setting-type="string"><db:data-source-setting-value>file:///home/YOUR_NORTHWIND_DIRECTORY/hsqldb.jar</

This is for Linux. I believe you need to replace /home with C: (or whatever drive).

Save the changed file, save the file in the archive and rerun the .odb. If changes were made correctly Base will open without a problem & without needing to alter the dangerous class path of Base.

edit retag flag offensive close merge delete

Comments

@peterwt Please notify if any problem. I believe all is in place.

Ratslinger gravatar imageRatslinger ( 2017-12-27 23:59:32 +0200 )edit