Ask Your Question
0

Wrong Numbering of Numbered lists of Sub-Documents rendered in Master Document

asked 2017-12-30 01:37:16 +0200

reddy gravatar image

updated 2017-12-30 01:52:01 +0200

I came across that bug apparently inherited from the OpenOffice codebase which is described in this forum.

Here is when this issue appears :

  • You have a Master document and attach multiple sub-documents to it
  • One of the sub-documents contains a numbered list incorrectly terminated. Let's say for the sake of giving an example that the number of the last item of this list is 5
  • The next numbered list that will be rendered in the Master document from a subsequent sub-document will start at 6 instead of starting at 1

This is a tricky one. The problem comes from this list incorrectly terminated business. Apparently, when a numbered list is created, it is followed by a line break which also adds the end-of-list mark behind the scenes. There are two issues :

  1. If this line break is removed, the end-of-list mark (not visible by the user) is also removed.
  2. The second problem is that manually adding a line break after a numbered list, after the line break automatically added when the numbered list was created has been deleted does not add back the hidden end-of-list mark.The only solution is to create a new numbered list (and to be careful not to delete the line break this time).

As you can imagine, this is pure voodoo for users and even when the problem is identified, this is a real pain to deal with. While the way numbered lists are terminated can be investigated, I think the real issue may be with the rendering engine of master documents. I mean, in my case the two numbered lists were separated by dozens of pages. There may be a counter variable that is not correctly reset (or it may be possible to manually reset it as a temporary hack as soon as content other than a list item is being met - which would signal the end of the list in the absence of the end of list mark). The problem only appears with multiple sub-documents rendered in a master document. As far as I can tell, numbered list in the same document are always correctly rendered outside of the context of a master document.

I am not familiar with the codebase of LibreOffice to send a patch. This is an annoying issue, hopefully it can be fixed soon. In the meantime, I found myself changing some numbered lists to bullet lists. This is the kind of bug that saddens me when I imagine how confused and frustrated a non-technical user must be in front of that.

edit retag flag offensive close merge delete

Comments

I don't understand: I never met the "end-of-list" blank paragraph. I restart numbering with right-click at end of first item and Restart Numbering. This attribute, which unfortunately cannot be set through a style -- it is strictly a manual attribute --, persists across master/slave documents (I just checked before commenting).

What is the origin of your doc? Is it an .odt?

How do you create your numbered lists? I only use dedicated styles.

ajlittoz gravatar imageajlittoz ( 2017-12-30 08:18:35 +0200 )edit

Amazingly enough, I changed the bullet lists in question back to numbered lists and everything now works. I however think that if the problem reoccurs, your right click + Restart Numbering solution, is the real solution (I didn't know it was possible to do that). I'll try that if it happens again but hopefully it won't. If you post your comment as a solution I will accept it. Many thanks for your assistance

reddy gravatar imagereddy ( 2017-12-31 01:51:08 +0200 )edit

Done, but I'm curious about this strange behaviour. Did you type entirely your document with LO Writer or have you imported it from some other doc processor?

ajlittoz gravatar imageajlittoz ( 2017-12-31 08:01:53 +0200 )edit

Many thanks for your interest, I'm curious about it too. I did type my document entirely in LO Writer, it wasn't an import. These are fresh .odt files attached to a .odm master document. No content was copy-pasted from another program or file format, everything was typed directly from LibreOffice.

reddy gravatar imagereddy ( 2017-12-31 19:39:33 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-12-31 08:00:11 +0200

ajlittoz gravatar image

The standard way to start a new numbering list, i.e. to force numbering from 1 for list items is as follows:

  • Put the cursor right before the paragraph mark of the "starting" list item
  • Right-click and choose Restart Numbering from the popup menu.

This adds some king of flag in the list item and the flag is kept through all manipulations of the text (copy/paste, master and slave documents, etc.).

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-30 01:37:16 +0200

Seen: 284 times

Last updated: Dec 31 '17