Ask Your Question
0

'My own Style' disappered - why?

asked 2018-01-12 16:33:58 +0100

luk gravatar image

Hi,

I created my own Style in Writer and saved it. I have some documenst where 'My Style' is added to 'Style list' and I can use it. But when I create a new document 'My Style' is not there.

After I opened a new document [LO Writer] my Style is not in the 'Style list'. But before, when I opened na new document it was there.

I also tried in Writer to use: 'Style-> Load style... ' , but it didn't help. After I use it, I can see in 'My themes' 'My Style' [in theme window]. But when I choose it and click 'Ok' it isn't added to the 'Style list'. I think I did the same action yesterday and it worked, now it doesn't.


What can be the issue?

Thanks for any help.

edit retag flag offensive close merge delete

Comments

No answer, so: nobody has got any idea on this or is my question not understandable? Should I describe it in different way? Any response?

luk gravatar imageluk ( 2018-01-19 21:58:56 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2018-01-31 15:59:16 +0100

paul1149 gravatar image

The best way to do this is by editing your default template. Go to Templates/manage templates, find the template you want to change and right-click for "edit". Create your styles there and Save. Any new document based on that template will have your custom styles.

edit flag offensive delete link more
1

answered 2018-01-31 15:28:17 +0100

johnnybaloney gravatar image

Firstly, just to clarify, custom styles are per document - for each new document you either have to create your styles from scratch or import them one way or another.

If you want to import then there are two options I know of:

  • create a new document, create and add the styles you want to reuse in the future to it, and save it as a template, or
  • import styles from an existing document using the Load Styles... menu option from the dropdown in the Styles and Formatting pane.

Watch out for gotchas. The last way is easy but not very user friendly. When you use it it will give you no feedback whatsoever what styles were imported, how many or if any at all (that's how it behaves in my version, which is 5.1.4.2). If the document you are importing the styles to is empty this may give you an impression that nothing happened but this may not be true.

At the bottom of the Styles and Formatting pane is a menu with style filters. Change it from Applied Styles (or whatever it is set to) to Custom Styles or All Styles and the styles from the document you were importing them from should appear. Also make sure you have the right kind of style category selected at the top of that pane, say, Paragraph Styles and not Page Styles, as the imported styles will only show up in the category they apply to.

edit flag offensive delete link more
1

answered 2018-01-31 17:02:59 +0100

luk gravatar image

Thanks for your ansewers.

I found also a perfect solution [more suitable for me] in this post: https://ask.libreoffice.org/en/questi...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-01-12 16:33:58 +0100

Seen: 64 times

Last updated: Jan 31