Ask Your Question
0

how are trailing decimal zeroes within a cell deleted

asked 2018-01-16 23:04:51 +0100

kengra gravatar image

how are trailing decimal zeroes within a cell deleted

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-01-16 23:44:08 +0100

librebel gravatar image

updated 2018-01-16 23:44:26 +0100

Hello @kengra,

  1. Select the entire number that you want to format;
  2. Right-click inside the selection, and choose the item Number Format...;
  3. In the dialog that pops up, in the textfield called “Format Code:”, type 0.# ( or if your locale uses the Comma as decimal separator, then type 0,# );
  4. Click OK.

HTH, lib

edit flag offensive delete link more

Comments

i inadvertently "answered" rather than "commenting". sorry

kengra gravatar imagekengra ( 2018-01-17 18:14:54 +0100 )edit
0

answered 2018-01-17 18:12:44 +0100

kengra gravatar image

I must be doing something wrong. i have a table column consisting of numbers with 0 to 4 decimal digits. the data was entered without trailing zeroes ( i.e. 1.2 not 1.2000). adding the zeroes gives me a different but wrong result. i've tried 0.#, #.# through 0.#### & #.#### i suspect i have to 1st clear the control l or R (left or right) formatting but can't figure out how using your 4.2 book. short of using a non proportional font to align numbers on the decimal point, please help. BTW i am using 6.0. thank you for trying to help.

edit flag offensive delete link more

Comments

Hello again @kengra,

To align the numbers at the decimal point, you could use the “?” symbol in your Format Code string as follows:

0.000?

or:

0.0???

For the correct alignment, the used font should indeed be a Monospace font, and the contents should be Right-aligned within the cell.

HTH, lib

librebel gravatar imagelibrebel ( 2018-01-17 18:44:33 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-01-16 23:04:51 +0100

Seen: 46 times

Last updated: Jan 17 '18