Ask Your Question
1

Base - List Box in a Form Grill - Data after update not showed [closed]

asked 2018-01-17 21:29:14 +0100

VHM gravatar image

updated 2020-08-05 00:14:52 +0100

Alex Kemp gravatar image

Hello Guys, I have learned a lot with your instructions, and I am struggling here. I created a relationship many to many. To do it, I created three tables. Table 1 - Program ID (Key) Program Name
Table 2 - ClassID (Key) NameClass Table 3 - Program Id (Foreign key) Class ID (Foreign key)

I created a Form: Main form: Table 1 (program Id and Program Name). SubForm: Table 3 Subform has a Table Control. The table control has a List Box with this command:"SELECT "ClassID" || ',' || "NameClass" FROM "Table2"" So, when the Form is active, the user choose a program, and, in the table, choose how many classes there is in the program. It is working good. The problem is, on the table, when the user is inserting the data, and moves from one record to another record (using the LIst Box), the previous information disappears. Example, line 1, user select class 1, Line 2, select class 3 but the information in line 1 disappear. Line 3, user select class 5, but the information in line 2 disappear. There is no problem with recording the data because all data are been recorded. I don`t know how to keep the information in the table when the user is inputting the data. Thank you for your help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-05 00:15:02.161282

Comments

Hello @VHM,

please upload a sample document so we can try to solve it in there.

librebel gravatar imagelibrebel ( 2018-01-17 21:49:40 +0100 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-01-17 22:25:24 +0100

librebel gravatar image

updated 2018-01-17 22:26:09 +0100

Hello @VHM,

I adapted your file a bit; please see if this is what you wanted:

C:\fakepath\15162224782991636copy.odb

With Regards, lib

edit flag offensive delete link more

Comments

Yeah! It is working very good now. I saw some changes, thank you very much. I am on a Mac computer, sometimes when I select SQL not work well, that`s why I choose SQL Native. Is that the problem that you fix? Regards, Victor

VHM gravatar imageVHM ( 2018-01-17 22:38:42 +0100 )edit
1

You're welcome! :D

Please mark this answer as correct by clicking on the checkmark icon to the left.

To be honest, i didn't inspect the properties before, but i built another from scratch.

Thank you, lib

librebel gravatar imagelibrebel ( 2018-01-17 22:44:05 +0100 )edit

Hi @librabel, I got it. Thank you very much! Have a nice day. Victor

VHM gravatar imageVHM ( 2018-01-17 22:53:09 +0100 )edit
0

answered 2018-01-17 21:55:39 +0100

VHM gravatar image

Here is the file.

C:\fakepath\Test.odb

Thank you for your help. Victor

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-01-17 21:29:14 +0100

Seen: 195 times

Last updated: Jan 17 '18