Ask Your Question
0

problems with .desktop files

asked 2018-01-26 08:19:46 +0100

fudoka gravatar image

I don't know if this is KDE-specific or a problem with the openSUSE packaging but I'm having a problem with the .desktop files supplied in the LibreOffice package for openSUSE 42.3.

Specifically, because the start of the .desktop file is a comment the mime type is not recognised without the .desktop file extension. I'm assuming that this breaks the magic number for the file

I want to rename links to the .desktop files so that they show up on a KDE desktop folder view with names such as "LibreOffice Calc" etc. but they just show up as text files once renamed and clicking on them opens the .desktop file in the kwrite editor.

There's a simple fix - just move the [Desktop Entry] line to the start of the document and everything is fine. I can do this on an ad-hoc basis but any upgrade will just overwrite them and I'd have to do the edit again.

Any idea where I can report this to get it fixed?

edit retag flag offensive close merge delete

Comments

... and better yet, prepare and post a patch to gerrit, so that it just gets merged, and not wait someone to be fixed. You can get any required help to get started at #libreoffice-dev (FreeNode).

Mike Kaganski gravatar imageMike Kaganski ( 2018-01-27 08:10:34 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-01-27 00:16:14 +0100

RGB-es gravatar image

I confirm the problem also on vanilla rpms downloaded from LibO site, so it's not an openSUSE issue but a general one. You can fill a bug report explaining the problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-01-26 08:19:46 +0100

Seen: 174 times

Last updated: Jan 27 '18