Ask Your Question
0

Create list with "List 1" paragraph style automatically in Writer [closed] [closed]

asked 2018-01-31 20:00:41 +0100

zeneto gravatar image

updated 2020-07-20 12:41:56 +0100

Alex Kemp gravatar image

I want, in Writer, to create lists (ordered and unordered), while typing, that automatically receive the paragraph style "List 1" (the list style "List 1" is working). I've enabled Autocorrect > Options > Apply numbering - symbol, which gives me a list in the case below as I type. How can I get it? For instance:

Typing the text below:

Normal paragraph
* list item 1
* list item 2
* list item 3 (last)

Following paragraph (after two hits of Enter)

Should give the following result:

Normal paragraph (text body style)

  • list item 1 ("List 1" paragraph style, "List 1" list style)
  • list item 2 ("List 1" paragraph style, "List 1" list style)
  • list item 3 (last) ("List 1" paragraph style, "List 1" list style)

Following paragraph (after two hits of Enter) (text body style, after Enter in the end of this line)

But what I get is (differences in bold):

Normal paragraph (text body style)

  • list item 1 ("Default" paragraph style, "List 1" list style)
  • list item 2 ("Default" paragraph style, "List 1" list style)
  • list item 3 (last) ("Default" paragraph style, "List 1" list style)

Following paragraph (after two hits of Enter) (text body style, after Enter in the end of this line)

How can I get the result that I want, automatically? I'm using LibreOffice 6.0.0.3 x64 on Windows 10. Thank you!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zeneto
close date 2018-02-02 19:50:09.382605

2 Answers

Sort by » oldest newest most voted
1

answered 2018-01-31 22:53:12 +0100

ajlittoz gravatar image

You can't do that "automatically" because though smart LibO may be it can't guess your intent against those of the millions other users. At least, you need to manually switch to List paragraph style at the beginning of your list and switch back to Text Body at end.

I find strange in your above question that your list is paragraph-styled Standard (I assume it is in fact Default Style unless you created a Default style). Even if you pressed the bullet button in the toolbar, your paragraph style would have remained Text Body.

I'm not using yet 6.x but I don't think specification changed here. If I type twice Enter after my list I get 2 empty items with their bullet. To stop the list, I must manually switch to Text Body.

A final caveat: you shouldn't use List for lists. This paragraph style is the ancestor of all styles List x and Numbering x and defines attributes common to all (the same as Default Style defines attributes common to all styles, which explains why it must not be used to type text).

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

I understand. I just thought that would be logical to associate the List (or List x, as you recommended) paragraph style with an automatically created list. But that's ok, though.

I use LibO in ptBR, so I just guessed that the name of Estilo Padrão should be Standard Style. I did mean Default style, And I forgot to mention that I have Autocorrect enabled for lists, which gives me the stop-list-with-two-Enters behaviour. Sorry by these inconveniences, I'll edit the question.

zeneto gravatar imagezeneto ( 2018-02-02 19:36:42 +0100 )edit
0

answered 2018-01-31 23:04:54 +0100

RGB-es gravatar image

[Your "but what I get" is identical to the "should give the following result" ;) ]

Notice that you can attach a number/bullet list to any paragraph style. Define a new paragraph style called, for example, my-listings. Be sure that this paragraph style is followed by itself and on the Outline & numbering tab select a numbered list, for example, List 1.

Now when you need to use the list just select my-listings paragraph style and when you need to turn back to normal text just press Enter and then Ctrl 0 to come back to "text body".

Notice also that under Tools → Customize → Keyboard tab it's possible to set a keyboard shortcut to the new style, so you can move from my-listings to Text body without leaving the keyboard.

edit flag offensive delete link more

Comments

The difference between what I get and should give the following result is on the styles LibreOffice attachs to each list item. Here, there's no visual difference, but in LO could be many visual differences, depending on the style configuration of List and Standard style (or, as ajlittoz showed, Default style).

zeneto gravatar imagezeneto ( 2018-02-02 19:19:49 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2018-01-31 20:00:41 +0100

Seen: 230 times

Last updated: Feb 02 '18