Missing dll file needed to open

asked 2018-02-03 10:38:39 +0200

suryasunder gravatar image

My LO version is 6. The error message I received was "The program can't start because api-ms-win-core-synch-l1-2-0.dll is missing from your computer. Try reinstalling the program to fix this problem." I uninstalled and installed LO-6 several times to rectify this problem. But LO 6 didn't run. I had been using LO 5.4 earlier without a hitch. I downloaded LO 6 as soon as I knew about its stable release. However, I installed the missing dll from the web and put it where it needed to be put. Then LO 6 asked for another dll file. I downloaded that dll file too and tried to run the program. It showed another missing dll issue. Finally it continued to show a missing dll issue that has been resolved, I mean, I have already downloaded and put the same file in my system 32 folder. What I am doing wrong here?

Incidentally, I had encountered the same problem with LO 5 in the earlier versions. I had reported the problem here and the glitch was rectified in later releases.

edit retag flag offensive close merge delete

Comments

It should have installed the needed redist at the end of installation of LO 6... didn't it ask you for admin credentials then? If no, then could you try to install with log, and post the log here?

Mike Kaganski gravatar imageMike Kaganski ( 2018-02-03 10:43:01 +0200 )edit

It did install the redist and no, it didn't ask for admin creds. Perhaps because I'm the only user and I don't have UAC enabled. I don't know how to install with log, would I need another software for that? Please advise.

suryasunder gravatar imagesuryasunder ( 2018-02-04 10:20:54 +0200 )edit

well, if it did, then no need, unfortunately.

Please remove the redist from Add/Remove programs, and reinstall from MS site.

Btw: what is your OS?

Mike Kaganski gravatar imageMike Kaganski ( 2018-02-04 10:42:48 +0200 )edit

The problem still persists in 6.0.3. The OS is now WIN7 X64.

suryasunder gravatar imagesuryasunder ( 2018-04-09 09:49:21 +0200 )edit

"... now ..."?

What was the OS before?

And what is the SP level of Win7? We only support Win7 SP1 and later, as mentioned on our system requirements page - cannot it be the problem here?

Mike Kaganski gravatar imageMike Kaganski ( 2018-04-09 10:04:00 +0200 )edit