Ask Your Question
0

MSO RC4 encryption is still supported in 5.3?

asked 2018-02-06 13:57:53 +0200

Winyl gravatar image

Libre Office 5.3.4.3 used to open RC4 encrypted Power Point presentation, but version 5.3.7 say "Opening of password encrypted Power Point document is not supported" when opening the same .pps LO used to open with version 5.3.4.3?

https://wiki.documentfoundation.org/R... The contemporary Microsoft Office default Binary Document encryption "RC4 CryptoAPI Encryption" is now supported (Caolán McNamara, Red Hat, Inc.)

edit retag flag offensive close merge delete

Comments

Without a sample file, it's hard to tell. Within an X.Y release, features don't get removed usually. Please provide a sample, maybe directly to bug tracker.

Mike Kaganski gravatar imageMike Kaganski ( 2018-02-06 14:11:59 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-02-28 11:02:24 +0200

Winyl gravatar image

On 5.4.5.1 LibreOffice is not showing the error Window "Opening of password protected Power Point document is not supported", but just silently exits/crashes when opening MSO RC4 encrypted pps file.

Mike Here you have the bug report with test files: https://bugs.documentfoundation.org/s...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-02-06 13:57:53 +0200

Seen: 53 times

Last updated: Feb 28 '18