Ask Your Question
0

[Solved] Stop header updating wrongly

asked 2018-02-12 08:38:48 +0200

RASP3 gravatar image

updated 2018-02-12 11:28:36 +0200

I am trying to format a 472 page manuscript in writer for publishing to paperback via PDF. I have set the required page size with mirrored margins and that has worked great. I have written new styles for the chapter start page so I have no header but a footer with the page number in the centre. That works great. I have left and right headers with the page number and title / author set-up for alternate pages, and that is 90% great. After I use the 'chapter start' style, I then manually break to the default style with the mirroring and headers as described, until the next 'chapter start' and so on through the book. On finishing I have proofread the formatting and that is where the issues are. On about 40 pages in the manuscript the header refuses to stay as the correct style, i.e. page # - author or Book Name page # (to alternate for the odd and even pages and keep the page #s on the outside). The pages in question are randomly placed, they are not the one immediately after the manual page break or at the end of the chapter, some are at the start of the chapter, some in the middle. I have turned off auto update where-ever I have found it in relation to my styles and headers. I have edited a page to correct the issue, saved the manuscript, only to go back to that page a few minutes later to find the wrong setting again. The other 430 pages are working correctly so the change does not change subsequent pages it is isolated. Any ideas would be gratefully received

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-02-12 09:45:12 +0200

RASP3 gravatar image

updated 2018-02-12 11:28:54 +0200

I just wrote a ream of explanation but think I have found the issue, if not the solution. (NB. No extra pages and the numbering is continuous and correct with no 'jumps'.)

In the drop down tag for each of the correct headers it says 'Left Page Header' or 'Right Page Header' which is correct. On the drop down tag for the anomalous pages it says 'First Page Header' which is incorrect and, I believe, the issue. The question now being how to change the incorrect tag to the correct one. I have tried placing the cursor in the incorrect header and choosing the correct header style, but it didn't change the tag.

EDIT OK, I definitely know what the problem is. The 'First Page Header' is what is causing the issue and it is the first page after the change back to 'Default'. For some reason the first default page is using 'First Page Header' instead of alternating between left and right, as is happening in the rest of the chapter. If, having found an incorrect header I change it to correct but then that changes the 'First Page Header' content. On all the 'First Page Header' pages which follow the same content as the one I changed the header looks correct but the other header is then wrong. Change the first 'First Page Header' and change them all. How do I get the first page of the default section to follow the 'left page' 'right page' header rules rather than put the 'First Page Header' in?

Solved - Went into format header and ticked 'Same Content on First Page' and that got rid of 'First Page Header' on the broken pages and set them all up 'Left / Right' as they should have been. I must admit that it wasn't very intuitive. I kept trying things until something worked.

edit flag offensive delete link more
0

answered 2018-02-12 08:52:14 +0200

RGB-es gravatar image

Difficult to say without seeing the actual document, but why do you use a manual page break to go from "chapter start" page style to "default"? When you set a page style, on the "Organizer" section you can set which style is the "Next style" so the style will automatically change without further work.

On print preview, see if there are automated blank pages inserted before the anomalous pages, maybe you have an unneeded page break that goes from a "left (or right) page" to another "left (or right) page", forcing Writer to insert a blank page between them. You can also check for this problem looking at the page number: odd pages are "right" while even pages are "left", so if in Writer you see your document going from, say, page 24 to page 26 you found the problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-02-12 08:38:48 +0200

Seen: 338 times

Last updated: Feb 12 '18