Ask Your Question
1

Font in Calc is changing [closed]

asked 2013-03-14 17:26:35 +0200

mikes gravatar image

I have been using LibreOffice for a while. Recently, when I drag some cells to other locations, and then begin to type in the now open cells, the font changes from Arial 10 to Calibri 11. I never made any changes that should cause that to happen. How can I return to having Arial 10? Getting very, very frustrated. Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-26 21:55:15.205864

4 Answers

Sort by » oldest newest most voted
0

answered 2013-03-14 22:18:37 +0200

razon_22 gravatar image

updated 2013-03-14 22:21:30 +0200

It's likely that the spreadsheet you are using was created in Excel. Calibri is the default font for it. And Arial is the default font for Calc. To change all the text to Arial again, click the small box to the left of the column A header to select all the text on the sheet. Then click the Styles and Formatting icon on the Formatting toolbar. The Styles and Formatting window will open. Right click on Default, choose Modify. Select the Font tab. If Arial 10 is not already selected, then select Arial from the Font list and 10 from the Size list. Click Ok. Now double click Default in the window and save the document. That should keep the font from changing even if you move cells around.

edit flag offensive delete link more
0

answered 2013-03-14 22:08:17 +0200

m.a.riosv gravatar image

I can not reproduce the issue with 3.6.5/4.0.2 in Windows 7x64 Please can you report you Operating System and you LibreOffice version.

edit flag offensive delete link more
0

answered 2013-03-15 02:17:58 +0200

ROSt52 gravatar image

This question let me go and see how my Calc behaves because I prefere Calibri over Arial. I observed a similar strange behavior of the fonts in Calc. Before reporting anything here, I would like to look at the default template which is used when I do file / new / spreadsheet.

Could you please tell me where this particular template is located and its file name?

edit flag offensive delete link more

Comments

There isn't a default template in Calc unless you create one. Once you create one, the template should be in the ...\AppData\Roaming\LibreOffice\4\user\template folder. See the answer to the following question. Instead of changing column width, go to Styles and Formatting and edit the 'Default' cell style to use the font you prefer and set it as the default template. http://ask.libreoffice.org/en/question/4619/how-does-one-change-default-value-of-column-width/

razon_22 gravatar imagerazon_22 ( 2013-03-15 03:25:22 +0200 )edit

@mfaile - Thanks for your reply. If there is no default template (I did not create one) from where does Calc pick up the font information? Can this setting be changed or do I need to create my own template and call e.g. MyCalcDefaultTemplate?

ROSt52 gravatar imageROSt52 ( 2013-03-15 09:38:35 +0200 )edit

@ROSt52 - Sorry, I gave some wrong info. There is a default template for each component in LibreOffice. It's in this folder on Win7: C:\Program Files (x86)\LibreOffice 4.0\share\template\shellnew It would be easier to just change the default styles in these files. In Writer, you can go to Tools > Options > LibreOffice Writer and choose Basic Fonts and you can change default fonts there as well. If you go to Tools > Options > Paths, you can see the default folder locations and go from there.

razon_22 gravatar imagerazon_22 ( 2013-03-15 12:08:20 +0200 )edit

@ROSt52 - (continuing previous answer) There seem to be two places templates are located, default templates are in the installation directory and user-created templates in appdata. So when I said there wasn't a default template, I was looking in the user-created templates folder and of course there won't be any templates in there in a fresh install.

razon_22 gravatar imagerazon_22 ( 2013-03-15 12:28:05 +0200 )edit
0

answered 2013-03-14 22:53:22 +0200

mikes gravatar image

Thanks for both of the answers. What I did is copied from Excel to Calc. Somehow that modified the Default. I went ahead and did the first suggestion and that did it! Thanks very much!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-14 17:26:35 +0200

Seen: 2,477 times

Last updated: Mar 15 '13