Ask Your Question
1

Formatting of new rows in Tables with LibreOffice Writer

asked 2018-02-19 18:15:12 +0100

elmulo gravatar image

I'm having an issue on LibreOffice 6.0.1.1 with tables in writer.

The formatting of the table suddenly changes when I add a new row to it. Which is not good if I've spent a long time carefully formatting all the rows. Step by step:

  1. New empty writer document
  2. Add a 2x1 table. That's already strange, because the font is Deja Vu Serif 12, but nowhere in my styles I have such a font. The current Style is Table Contents. If I edit the Table Contents style it shows Open Sans Light 10,5 instead.
  3. If select the cells and press Clear Direct Formatting nothing happens.
  4. I select Default Style from the drop down menu and the font is now Open Sans Light 10,5.
  5. I type "hello" into a cell.
  6. I press TAB until a new row is inserted.
  7. Suddenly the whole table is now Deja Vu Serif 12 again, Default Style.
  8. If I select the table and choose Clear Direct Formatting nothing happens.
  9. If I choose Default Style, even if it's already selected, it becomes Open Sans Light 10,5 again.
  10. If I choose Clear Direct Formatting, the font goes back to Deja Vu Serif 12, the style is still Default Style.

Somewhere it has stored this Deja Vu Serif 12 font, but not on my styles...

Any suggestions?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-02-19 22:35:24 +0100

context15 gravatar image

This is part of a bug (115573) that goes back maybe as far as 5.3.7.2. See also my question/answer here in "Writer reverts changes to table content style if row inserted/deleted". As a work around:

1 Select the "Auto Format Styles" button or drop-down selection of the Table menu 2 Select any of the styles, it doesn't matter which is chosen 3 Let it be applied 4 Use Ctl-Z to revert the auto format selection

edit flag offensive delete link more

Comments

Thank you very much for this. I set a shortcut key CTRL+ALT+F (for fix) to the 3D table style. That means now I can:

  1. Insert new row (formatting breaks)
  2. Press CTRL+ALT+F (formatting breaks even more)
  3. Press CTRL+Z (formatting fixed, new row still there!)

I can work again :)

elmulo gravatar imageelmulo ( 2018-02-20 10:59:04 +0100 )edit
0

answered 2018-04-12 00:31:08 +0100

The "AutoFormat and reverse" workaround still didn't resolve this bug on my version of LI (6.0.2.1 x64). But I was able to create an own AutoFormat style, that doesn't break after inserting of new rows:

  1. Create a new/ attribute a paragraph style other than "Table Contents" onto the table cells
  2. Format borders, headlines, etc.
  3. Select the table
  4. Go to Tables > AutoFormat and click to Add
  5. Name your custom style

Hope, someone can reproduce this.

edit flag offensive delete link more

Comments

yes, submoss, this is working! thank you so much! (unfortunately, i'm not allowed to up-vote your answer, but i would)

goodguy00 gravatar imagegoodguy00 ( 2018-12-13 00:10:18 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-02-19 18:15:12 +0100

Seen: 513 times

Last updated: Dec 13 '18