Ask Your Question
0

.csv problem [closed]

asked 2018-03-03 22:36:56 +0200

tjhhpp gravatar image

updated 2018-03-03 22:53:03 +0200

All my .csv files have suddenly turned into a single line of Japanese characters. What has happened?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by m.a.riosv
close date 2018-03-04 22:36:32.125901

1 Answer

Sort by » oldest newest most voted
0

answered 2018-03-04 18:27:57 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I now have the answer. The imported data was in the UTF-16 character set. This must have changed when LibreOffice 6.0.1.1 was downloaded, despite it having been OK with the previous version. Changing to UTF-8 cured the problem.

edit flag offensive delete link more

Comments

More likely UTF-16 was selected once for a different import, which may happen automatically if the file content was prefixed with a Unicode UTF-16-BOM. The selection is remembered in the user configuration profile to be presented for the next CSV import.

erAck gravatar imageerAck ( 2018-03-05 17:40:17 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2018-03-03 22:36:56 +0200

Seen: 52 times

Last updated: Mar 04 '18