Bad scrolling behaviour with touchpad/magic mouse (Win/Mac)

asked 2018-03-06 12:51:07 +0200

CharlesV gravatar image

updated 2018-03-06 17:38:11 +0200

I am using LibreOffice on Windows and recently installed it on a Mac. Since I have been using it on my Windows laptop, the scrolling with the touchpad is almost useless as it is way too fast. I am using a mouse mostly and the mousewheel behaves as expected, so it was alright, but still annoying whenever I had to use the touchpad (or rather had to rely on the keyboard for scrolling).

The installation on a new Mac worked just fine but again I experience a very annoying scrolling behaviour, in this case with the magic mouse (scrolling with one or two fingers). Here, the scrolling is very unsmooth, maybe a bit too slow, but just not as elegant as in all other applications. All other applications on the Windows laptop work flawlessly as well so it has to be LO-related.

I found some possibly related questions on all kind of platforms, sometimes years old, but no adaptable solution was provided:

https://ask.libreoffice.org/en/questi...

https://forum.manjaro.org/t/libre-off...

https://bugs.documentfoundation.org/s...

https://bugzilla.redhat.com/show_bug....

I wonder whether a) everyone has the same behaviour but doesn't really bother (highly unlikely) or b) what is wrong with my installation. The installation on the Mac is completely fresh and new and I have recently updated to LO6 after uninstalling the previous version on Windows.

Any help is really appreciated! I highly prefer LO over MS Office but such a major flaw in the GUI is severe.

/Edit: For additional information, I was using OpenOffice before and had the same problem (scrolling too fast with touchpad), see here (not my post): https://forum.openoffice.org/en/forum...

edit retag flag offensive close merge delete

Comments

check https://ask.libreoffice.org/en/questi... and https://ask.libreoffice.org/en/questi... for answers.. my project at http://essaytyper.pro did benefit a lot from these discussions, particularly from this advice: Go to Tools > Options > choose View > set the Middle mouse button dropdown to Automatic scrolling

gr8h8m gravatar imagegr8h8m ( 2018-03-13 14:07:36 +0200 )edit