Ask Your Question
1

How to change default text box font in calc

asked 2018-03-10 12:34:36 +0200

MG312 gravatar image

updated 2018-03-13 18:24:10 +0200

I've Googled this but all the solutions I've found do not work.

Every time I add a text box (edit - actually a shape inserted as a graphical object,) into a calc doc it defaults to Liberation Serif 12, which I would like to change.

I click inside the text box, then F11 which brings up the Styles and Formatting side bar. This lists the options of Default Heading Heading1 etc etc. Right clicking on these options brings up a second option Modify, but I can't do anything with this. Clicking on it does nothing. What am I doing wrong, or not doing?

edit retag flag offensive close merge delete

Comments

Please edit your question to make clear that your questin is about a shape inserted as a graphical object from the drawing toolbar. The term 'Text Box' unfortunately is also used for a kind of form control.

Lupp gravatar imageLupp ( 2018-03-13 10:45:25 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2018-03-13 10:12:52 +0200

RGB-es gravatar image

Short answer: you can't. Long answer: there are no graphic styles on Calc nor Writer

Bug 89369 - Add support for drawing styles (shapes and textboxes) to Writer and Calc

An even longer answer: but there is a workaround. On the Drawing toolbar click the button to add a text box but BEFORE going to the document move to the Properties panel on the sidebar and select the font, font size, etc, ONLY THEN go to the document to insert the text box: the settings you've chosen will be maintained for the rest of the session.

edit flag offensive delete link more

Comments

1

...or/and manage a collection of shapes yourself in a dedicated sheet of your Calc template and use the specimens from that collection as a kind of surrogate for templates by Copy/Paste. Before saving your document as a final version you may then delete the 'CollectionSheet'.
To do it in a similar way for a Writer document you may use a 'CollectionFrame'.
Of course, once created 'children' will not inherit from the pseudo templates later-on.

Lupp gravatar imageLupp ( 2018-03-13 10:34:11 +0200 )edit

Thank you for your comprehensive and helpful reply. Now I know what I can and cannot do, and the workaround is certainly better than nothing.

MG312 gravatar imageMG312 ( 2018-03-13 18:22:54 +0200 )edit
1

answered 2018-03-10 13:50:22 +0200

peterwt gravatar image

updated 2018-03-14 12:34:10 +0200

You need to be set in design mode. Select the Text Box and right click which bring up a list. Select Control and the Properties list for the Text Box is available, where you can set the Font.

EDITED 14/03/2018

@MG312 I assumed that you had created the text box using the Forms Controls collection. My explanation applies to that. You have edited your question to show that you created the text box as a graphics object. You were nearly there in the steps you took. Having got the Styles and Formatting side bar displaying click on the spanner icon and this will open the Properties tab where you can change Fonts etc.

edit flag offensive delete link more

Comments

Thanks, Peter, but that doesn't work. I don't have an option for Control. When I right click with the cursor flashing in the text box the only options are Cut, Copy, Default, Text, Character, Paragraph. If I select the text box so there is no cursor flashing there are more options but none are "Control"

Any more ideas, please?

MG312 gravatar imageMG312 ( 2018-03-12 18:17:22 +0200 )edit

The question obviously was about any 'Text Box' inserted as a shape from the drawing toolbar.
Above answer applies to form controls of type 'Text Box'. Unfortunately LibO uses the term 'Text Box' for two rather different object types. .

Lupp gravatar imageLupp ( 2018-03-13 10:43:09 +0200 )edit
0

answered 2018-03-12 18:19:42 +0200

MG312 gravatar image

Thanks, Peter, but that doesn't work. I don't have an option for Control. When I right click with the cursor flashing in the text box the only options are Cut, Copy, Default, Text, Character, Paragraph. If I select the text box so there is no cursor flashing there are more options but none are "Control"

Any more ideas, please?

edit flag offensive delete link more

Comments

1

@MG312: This isn't an answer but a comment on the first answer given. Would you object to my suggestion to delete it?

Lupp gravatar imageLupp ( 2018-03-13 10:47:24 +0200 )edit

Hi Lupp Sorry I am unclear about this. If I click on delete it deletes your comment on my post. I did originally enter a comment but it did not move my thread back up the list, so I assumed no-one would look back that far to see it. That is why I answered rather than commenting. I apologise if I acted incorrectly.

MG312 gravatar imageMG312 ( 2018-03-13 18:23:29 +0200 )edit

Don't worry! And it isn't exatly "bad behaviour" to bump a question. The poor structure of this site (breathlessly running ticker) may increase the need. If actually necessary you might, however, better bump by adding some info to your question. Edit it for the purpose.

Lupp gravatar imageLupp ( 2018-03-13 18:42:55 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-03-10 12:34:36 +0200

Seen: 144 times

Last updated: Mar 14