Ask Your Question
1

dead keys won't work [closed]

asked 2013-03-21 11:10:18 +0200

vywus gravatar image

updated 2015-11-04 04:45:03 +0200

Alex Kemp gravatar image

I'm on arch linux, i'm using the fr layout and I can use dead keys " ^ ä â everywhere BUT in libreoffice. In libreoffice the ^ key don't do anything. What can I do ?

I've got news, I found out that I have the french BSD unix thing keyboard : http://fr.wikipedia.org/wiki/Disposition_des_touches_des_claviers_informatiques#Clavier_fran.C3.A7ais_sous_Xorg_.28GNU.2FLinux.2C_.2ABSD_et_autres_UNIX.29

Edit2: Okay I don't have this exact same keyboard, but at least now I now I don't have the basic azerty keyboard. How can I use something to run lowriter with azerty default keyboard ?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-04 04:45:22.175150

Comments

Every other keys work inside or outside of open office €æéçè.. Only sticky keys indeed. I've installed libreoffice-fr and all the setting are set to french. Disabling autocorrect and other fonctions don't change anything. I use setxkbmap fr and other things to "fr_FR.UTF-8" But I don't think it's because of the layout, everything work well outisde of LO. Version 4.0.1.2 (Build ID: 4.0.1.2 Arch Linux build-2)

vywus gravatar imagevywus ( 2013-03-21 15:39:52 +0200 )edit

@vywus -- Is this question a duplicate of your previous one? http://ask.libreoffice.org/en/question/14920/the-and-keys-dont-work/

qubit gravatar imagequbit ( 2013-03-21 19:00:05 +0200 )edit

@petermau Yeh.. At first it was really frustrating and weird that the problem is only with LibO. But it looks like it just doesn't work the same way.

Thanks for the workaround, but ^e is faster. I'll post on the arch forums, now I know they can help me. Thanks again for the help, I spent so much time on this.

vywus gravatar imagevywus ( 2013-03-22 18:49:13 +0200 )edit

The OP isn't the only person experiencing this problem. There are a couple bug reports concerning nonfunctional dead keys in LibreOffice. The problem may be related to IBUS. See https://bugs.freedesktop.org/show_bug.cgi?id=71437 for further details.

psychonaut gravatar imagepsychonaut ( 2014-02-07 18:06:27 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-03-22 10:05:44 +0200

petermau gravatar image

@vyzus;

It is normally the Arch Linux system that is controlling the keyboard and the sticky keys not LibO. When I change keyboards between English, French and Swiss I tell my Ubuntu system, LibO does not know, it just uses the characters it is given.

You can also input characters such as î or ë as I am doing now using Unicode by holding down the Ctrl and shift characters, typing U and then the code, UEE gives î, for example. This may help your particular characters you are encountering difficulties with.

Does the Arch Linux forum help on setting up your AZERTY keyboard?

edit flag offensive delete link more
0

answered 2013-03-21 14:59:41 +0200

petermau gravatar image

@vyzus;

Are all the other standard French accent keys working as you would expect? For example Lower case (7è 9ç 0à 2é) Alt-Gr-a æ Alt-Gr-q @ etc. In other words it is just the sticky keys that are giving you the problem or all the French accents.

Have you installed the French Language package or are you just using the default Eng-US? And the Language settings are set to French? Tools > Options > Language settings > French It is also worth looking to make certain that the Autocorrect function is not overwriting your text. Tools > Autocorrect options.

As a temporary help, not a solution, I have used the French spellcheck to correct the missing accents. (French is not my native language)

What version of LibreOffice are you using? I can't reproduce your problem using LibO 3.6.4, 4.0.1 on Ubuntu 12.04 with a UK, French-French or Swiss-French keyboard. Sorry not to be more help.

edit flag offensive delete link more
0

answered 2013-07-27 19:37:48 +0200

cleydyr gravatar image

updated 2013-07-27 19:38:18 +0200

Hi, vywus.

I had the same problem using Arch, but after installed libreoffice-gnome, it worked well for me.

pacman -S libreoffice-gnome

Hope it helps.

Regards.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-21 11:10:18 +0200

Seen: 1,259 times

Last updated: Jul 27 '13