Ask Your Question
1

LO 6.0.2.1 Calc cannot switch between documents on a Mac [closed]

asked 2018-03-18 03:24:42 +0100

dopund gravatar image

updated 2018-03-19 12:08:33 +0100

David gravatar image

Yesterday I updated LO to 6.0.2.1, then I cannot use Command + ` to swtich between documents as the 5.x version does. The shortcut seems bind to a new function, like to mask cells which containing formulas.

I cannot find how to change the shortcut bindings. Tools -> Customize... not work.

How to set Command + ` to switch between documents?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by erAck
close date 2018-03-21 13:04:22.070001

Comments

I wish I knew. It seems to work with Write documents, but not Calc.

Liberty Belle gravatar imageLiberty Belle ( 2018-03-18 04:29:54 +0100 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2018-03-18 11:44:41 +0100

David gravatar image

updated 2018-03-19 11:22:04 +0100

This key combination is a toggle that "Displays or hides the formulas instead of the values in all cells." (Search for the back-tick on that page to see the instructions/explanation.)

This is a known bug: fdo#103388. At least since January it has been registered as an issue for OSX. (And I can confirm!) [ Update - As noted by @vsfoote, this has been fixed, and will be available when you get v. 6.0.3+ for OSX. I'm still on 6.0.1, though.]

There is a workaround, but it is very much USE AT YOUR OWN RISK :)

  • Open LibO Preferences (⌘,)
  • Open the first category, LibreOffice > Advanced,
  • click on Open Expert Configuration.
  • in the "search" bar in the new pop-up, type: "toggleFormula" and hit ENTER. This will bring up a function that includes QUOTELEFT_MOD1:

    screenshot

    Double-click that line, and clear the value .uno:ToggleFormula from the box that pops up.

  • Click OK (for each of the three pop-up windows).

Now ⌘` will work on the system level, and you'll be able to use that key combination to switch between Calc windows.

It is a simple matter to reverse this operation, of course, but you now need to search on QUOTELEFT_MOD1 to find that function.
 

edit flag offensive delete link more
1

answered 2018-03-18 14:32:47 +0100

vsfoote gravatar image

updated 2018-03-18 14:33:21 +0100

The uno:ToggleFormula command's shortcut was reassigned from QUOTELEFT_MOD1 (Cmd+`) to QUOTELEFT_MOD3 (Ctrl+`) on macOS builds. Available at 6.0.3 and 6.1.0 release, restoring the macOS UI HIG usage. See tdf#114858.

This affects earlier builds as well (the assignment was inherited from OOo era). The Expert Configuration change listed is effective (just revert it when moving to 6.0.3) or alternatively just use macOS Shift+Cmd+` to move between app windows in reverse order--same effect.

edit flag offensive delete link more

Comments

I'm on a Mac OSX build on this machine, using 6.0.1.1, and it's still set to Cmd+`, I'm afraid. :( Hopefully this will come through at some point (soon). Good suggestion about Shift+Cmd+`, though.

David gravatar imageDavid ( 2018-03-18 14:47:01 +0100 )edit
-1

answered 2018-03-18 19:19:06 +0100

jerkstore112233 gravatar image

I'm sorry but that's just completely ridiculous. You don't mess with system wide default keyboard shortcuts.I don't know what's going on with LO lately, but somewhere in the 5.x line people started really letting this app go. The Document Foundation needs to get it's act together.

edit flag offensive delete link more

Comments

And this is an answer??

David gravatar imageDavid ( 2018-03-18 19:34:42 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2018-03-18 03:24:42 +0100

Seen: 171 times

Last updated: Mar 19 '18