Ask Your Question
1

Can't change the page margins in my default template

asked 2018-03-20 01:43:16 +0200

snovotill gravatar image

I go to File / Templates / Manage Templates / Default / Edit. The Page layout menu is grayed out under "Format / Page" so I give up.

Next I try to create a new Default.ott with my desired Page Margins and I overwrite C:\Program Files\LibreOffice\share\template\common\styles\Default.ott But to no avail, because when I then create a new document it does not respect my custom margins from Default.ott

Is the world evil?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2018-03-20 09:28:13 +0200

gabix gravatar image

updated 2018-03-20 10:51:48 +0200

David gravatar image

It looks like you did not set your template as the default. Do it. Merely naming it as Default.ott is not enough.

To set a template as "defaul":

  • go to File > Templates > Manage Templates,
  • find the template you want to set as "default",
  • right-click on it and choose Set As Default.

A "check" icon will now appear with it to show it is the designated default.

edit flag offensive delete link more

Comments

David, thanks for amending my answer!

gabix gravatar imagegabix ( 2018-03-20 12:13:10 +0200 )edit

Hmm, I've verified that the template does indeed sport the "default" tick mark, but it doesn't get invoked. For example I'll right-click on the "windows desktop" and select "New - OpenDocument Text", but the document does not inherit my customized margins from the template. Yet when I check the template itself I can see the custom margins are there. I'm using 6.0.2.1

snovotill gravatar imagesnovotill ( 2018-03-20 23:15:30 +0200 )edit

This is weird, if I create a new document as described in my comment directly above then my default template fails to apply, however if I create a new document from Start / All-Programs / LibreOffice / Writer, then the template inherits just fine! I'm thinking there must be another setting for this somewhere?

snovotill gravatar imagesnovotill ( 2018-03-20 23:19:45 +0200 )edit
1

answered 2018-03-20 23:36:06 +0200

peterwt gravatar image

Your comment that you are using right click on Windows desktop - New - OpenDocument Text to create a new document is the source of your problem.
When you use the right click context menu New for OpenDocument Text it does not use the default template set for a writer document. There are a set of different templates used for this. They are located at Program Files\LibreOffice (ver)\share\template\shellnew. For a Writer document it is soffice.odt - a file and not a template. You will need to modify this. Some people have reported that spellcheck does not work on documents created using the context menu.

edit flag offensive delete link more

Comments

Thanks for the explanation and WOW that's bad-dog feature! My googling certainly wasn't quite Zen enough to blow through this TEST.

snovotill gravatar imagesnovotill ( 2018-03-23 06:33:28 +0200 )edit
0

answered 2018-03-22 19:44:17 +0200

snovotill gravatar image

The problem was that default templates don't work when creating a new document by right-clicking in a folder and then selecting "New OpenDocument Text".

It is necessary to start LibreOffice Writer from the Windows START button menu's instead, and then select NEW document.

Looks to be a bug.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-03-20 01:43:16 +0200

Seen: 213 times

Last updated: Mar 22 '18