Ask Your Question
0

Prevent changing of font size in table (Writer)

asked 2018-03-28 10:00:10 +0100

CharlesV gravatar image

updated 2018-03-28 10:33:24 +0100

Whenever I add a column or row in a table in writer, the font size of all cells is set to 12 although I set a smaller font. How can I prevent the automatic change / adjusting of the font size in a table?

Edit: The question seems to have come up before of which I was unaware: https://ask.libreoffice.org/en/questi...

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-03-28 10:40:45 +0100

ajlittoz gravatar image

updated 2018-03-28 14:38:00 +0100

This occurs because you forced font size "manually" (aka. direct formatting) using the size menu in the toolbar.

Whenever you enter a new cell (an empty one in same row or automatically added empty cells in new row), paragraph style for the new cell reverts to Table Contents with attributes values as defined in the style.

If you want to make your change persistent, modify Table Contents paragraph style.

If you are not familiar with styles, read the Writer Guide available for download on the documentation pageof LibreOffice.org. This is an excellent reading to master the tremendous possibilities offered by Writer.

EDIT after reading carefully bug 115573 report:

Tables work as I expect here but bug 115573 mentions it is related to table styles.

In my opinion, table "styles" are presently templates rather than styles like paragraph, character, page or list styles. You can't tune your tables once they've been created just like you can do with styles. Note, for example, you can't create your own table "styles" nor modify provided ones, meaning only built-in "styles" are accepted by LO Writer.

This is why I prefer to create my tables manually (equivalent to Default Style) and massage them until I'm satisfied. Then if two tables must be similar, I copy/paste the first one to the appropriate location.

I personally find the present table style too "flashy" to be used in technical papers or other "official" (boring?) documents. In another question about table styles (I can't find the reference immediately), one of the LO gurus admitted the feature to be rather experimental. My advice would be then to keep away from it and wait until it stabilises and matures toward integration into the other styles design.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Thank you! So I changed the font size of the table contents paragraph style to 9 but the size is still increased to 12 when I enter a new cell. What did I miss to do?

CharlesV gravatar imageCharlesV ( 2018-03-28 11:42:44 +0100 )edit

What did I miss to do?

In my view you did not miss anything to do. But LibreOffice did. For better handling alter the styles (Table and/or TableContents; where is the difference?), select the entire table, then double click on style, then the table's/cells' properties alter.

But be careful. If you hit the short-cut CTRL+m in one cell - all other cells change into Liberation Serif 12 (or other default, I cannot say at the moment...). It seems to be a bug, at least it is cumbersome.

Grantler gravatar imageGrantler ( 2018-03-28 14:18:40 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-03-28 10:00:10 +0100

Seen: 457 times

Last updated: Mar 28 '18