Disappearing Autocorrect

asked 2018-04-01 02:05:06 +0200

nsivin gravatar image

updated 2018-04-04 02:06:31 +0200

I am using LibreOffice v. 5.1.6.2 under Linux Mint (see setup below). I use Autocorrect extensively to abbreviate long words (e.g., ;e = English, asty = astronomy; I have gotten rid of the spelling corrections that populate the file as it comes). The file I use was about 73KB. Yesterday, without my being aware of a reason, the whole Autocorrect file, acor_en-US.dat, disappeared. When I replaced it with a backup, it no longer worked. I then tried deleting the file and recording a couple of autocorrections so I could see where they were recorded. When I finished, they just disappeared. I then deleted and reinstalled LO to see whether that would provide a new copy of acor_en-US.dat. It didn’t. In other words, I can’t understand what has happened, and have no way of replacing the file. Does anyone have an idea what could have happened? Please let me know if you need more information.

Setup, Desktop End PC Noise custom AMD Fusion Media PC AMD A8-3850 2.9GHz quad-core CPU 4GB Kingston PC3 RAM 2 Intel 520 series 120GB SATA III SSD Dell 24” pivot monitor, normally used in portrait mode Northgate Omnikey Ultra keyboard Linux Mint 18.3 Mate 2 Intel 520 series 120GB SATA III SSD Dell 24” pivot monitor, normally used in portrait mode Northgate Omnikey Ultra keyboard Linux Mint 18.3 Mate

edit retag flag offensive close merge delete

Comments

Where did you paste you backup?

Kruno gravatar imageKruno ( 2018-04-01 12:20:38 +0200 )edit

I didn't paste the backup. I have a backup file in another partition, and simply copied it from there to the default location (I also back up all my files weekly, so I have another backup on a second disk---which occasionally turns out to be very usefull.

I should add that I have only installed LO Writer and Calc, since I have no need for the other parts.

nsivin gravatar imagensivin ( 2018-04-03 01:44:36 +0200 )edit

What is your default location? That's what I wanted to ask previously.

Kruno gravatar imageKruno ( 2018-04-03 21:50:31 +0200 )edit

The default location for the Autocorrect file is usr/lib/libreoffice/share/autocorr/acor_en-US.dat.

nsivin gravatar imagensivin ( 2018-04-04 02:02:28 +0200 )edit

Well no. LibreOffice first checks your home folder as there's .dat file also. On Debian Stretch it's /home/user/.config/libreoffice/4/user/autocorr/. Backup what's already there and paste your backup on that location. Maybe you have that folder empty or you named .dat file wrong. Think this will help.

Kruno gravatar imageKruno ( 2018-04-04 15:22:21 +0200 )edit