Ask Your Question
1

Copy text only

asked 2018-04-16 11:08:25 +0200

chebaev gravatar image

Hi!

How can i make funtion when i copy text from LibreOffice Whriter and paste it in other program to copy only text whithouth formating?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2018-04-16 11:21:18 +0200

This is the other program's function.

LibreOffice follows the OS guidelines when works with the system clipboard. E.g., on Windows, it provides to the clipboard all the formats it is able to send, including plain text. Then, when the other program pastes, it looks into the clipboard to get the list of available formats, and selects the format it needs - that might be "the best" format (when user pastes using default Paste) - when the program selects the available format that the other program also supports, and which offers the best formatting carried over; or the other program may use "Paste Special" and let user explicitly choose from the available formats.

So - look for the "Paste Special" function in the target program, and choose the Plain Text there.

edit flag offensive delete link more
0

answered 2020-01-20 14:38:21 +0200

I too would like to send only the text to the clipboard, excluding all the formatting. Many a time I would like to insert text in the formatting of the target document and not the source. Moreover, LibreOffice Writer crashes upon multiple Paste commands and my impression is that the bug is linked to the formatting data sent to the clipboard. A bug had been filed but was abated due to lack of provability :(.

My conclusion is that, as yet, LibreOffice does not have a "Copy text only" feature. I would include this as a wished-for functionality.

edit flag offensive delete link more
0

answered 2018-04-16 17:01:24 +0200

chebaev gravatar image

Till today everything was perfect. I used LibreOffice 5 and when i copy the text from Writer and paste it into another program (for example, Sony Vegas Pro) was perfect, the text was paste it without formatting, just text only. Today i decided to upgrade to version 6 of LibreOffice. After updating when i copy text from Writer and paste it in another program, the text paste it with formatting (color, font, size ....) I tried to install again LibreOffice 5, but the problem is the same.

edit flag offensive delete link more

Comments

Can you refute the statements by @Mike Kanganski concrning rhe relevant role played by the other application? Wouldn't you complain about missing features if you wanted a formatted copy and got only an unformatted one without any choice.?

Lupp gravatar imageLupp ( 2018-04-16 17:18:11 +0200 )edit
0

answered 2018-04-16 17:24:27 +0200

Lupp gravatar image

updated 2018-04-16 17:31:44 +0200

If you want to get rid of formats, and the target application doesn't support a Paste Special... allowing for that, simply open a second Writer document serving as an interstation. Then Paste Special... therein your copied text as 'Unfotmatted text', copy it again, and paste it wherever you want.

An alternative: Select text for copy - Ctrl+M to remove formats - Ctrl+C fot copy - Ctrl+Z for undo Ctrl+M ...

You may also program your own Copy Special... tool, of course.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-16 11:08:25 +0200

Seen: 2,017 times

Last updated: Jan 20