How can I force the formatting in a table in Writer so new rows added at the end of the table with the tab key take on the correct font?

asked 2018-04-23 02:18:03 +0200

tech-doc gravatar image

I have a Writer template, set as my default, which is set with a standard SANS serif font (in the "Default style", and as far as I know everywhere else). When I create a new Writer document, the default table style "Table Contents" is set to that same standard font, but all cells of an inserted table are in Liberation Serif, NOT the desired font. Whenever I add a row to the bottom of the table using the tab, the new cells are also set to the "Table Contents" style, but are also set to Liberation Serif.

I have all autoformat options OFF.

The problem appears to be that even though I do not want to use table autoformat, I appear not to be able to disable it, and when I create a new table, unless I consciously select my own previously saved table format from the "AutoFormat" dropdown dialog on the "Insert Table" dialog, I get the "Default style" [which in itself is extremely confusing terminology, since this refers to a separate table [autoformat] style, not the base document "Default style"!], which I cannot actually edit or delete? How can I force the style template to always use my settings for tables?

I am using 6.0.2.1

edit retag flag offensive close merge delete