Ask Your Question
0

Cannot change heading appearance: Applied style is bold, 12pt

asked 2018-04-23 18:37:55 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In LibreOffice 5.4.6.2:

I have a weird problem where I have a line that is styled as "Heading 1" but that appears as "bold, 12 pt" only with no good reason. Reapplying "Heading 1" style changes nothing.

The heading in question is "heading cannot change" in the attached document.

If I fumble around in the text there is a point where the Heading Style Change becomes apply-able again, but I have not found a consistent pattern regarding when this occurs.

It sounds like a bug, but maybe I'm just missing something.

C:\fakepath\Heading Recalcitrance.odt

edit retag flag offensive close merge delete

Comments

@Jacques Guddebuer - Please don't post as "community wiki" -- this isn't a "wiki" question, and now you won't be able to "earn" reputation ("karma") from this post to build up your profile on the site.

David gravatar imageDavid ( 2018-04-23 19:31:25 +0100 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2018-04-23 19:40:43 +0100

ajlittoz gravatar image

As is usual in such a circumstance, you applied some direct formatting to your "unchangeable" paragraph.

To fix the problem, select the whole content of your problematic paragraph (your "frozen" Heading 1 paragraph) and Format>Clear Direct Formatting or Cntrl+M.

The reason lies in the precedence of styles:

  • at the deepest level, attributes are set as per Tools>Options, various parameters, among which Language settings>Languages and LibreOffice Writer>Standard Fonts

  • next paragraph styles organised hierarchically (they all depend ultimately on Standard Style)

  • next character styles

  • finally direct formatting, i.e. attributes you set manually with buttons and menu items.

Each layer overrides those beneath. Direct formatting being the top layer is overridden by none and must be explicitly cleared. Otherwise it hides the corresponding attributes set by styles.

If you want to be immune to such annoyance, avoid direct formatting. It is the root of all evil. This means you must design your own set of consistent styles (i.e. customising at least the built-in styles to fit your needs) in paragraph and character categories at minimum.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

BTW: you shouldn't have posted as wiki because it prevents from answering adequately on personal problems and does not grant you karma points needed to better navigate on this site.

edit flag offensive delete link more

Comments

Got it! Very complete explanation. Actually I thought it might be something along those lines and I tried "Clear Formatting" (as opposed to Format->Clear Direct Formatting) from the drop-down containing the available styles, but this didn't work. At some point, repeatedly applying the "Heading 1" even resulted unexpectedly in success, which left me even more confused.

Jacques Guddebuer gravatar imageJacques Guddebuer ( 2018-04-24 09:56:39 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-23 18:37:55 +0100

Seen: 86 times

Last updated: Apr 23 '18