Ask Your Question
0

Apostrophe in writer

asked 2018-04-26 11:17:46 +0200

Chelobaka gravatar image

Hello. I noticed a strange behaviour in Writer. If I type apostrophe from keyboard:

'

it changes to quotes:

My locales and interface are set to Russian. It happens when I create new document (by default text language is set to Russian) and start typing. As soon as I switch keyboard to English (or any latinic layout) and type something in English (or any other language, where apostrophe is needed, it is needed even in Russian sometimes), apostrophe gets replaced by quote. But switching text language to English helps, it stops replacing letters, but what if I need this symbol in Russian language? change text language for this particular symbol?

It's a very strange behavior, because apostrophe is unreachable from Russian keyboard layout. I can't imagine, who and why could use this autoreplacing by default, very weird. Maybe it's someones dirty hack to make something very rare and uncommon? This shouldn't be turned on by default. Fix me if I am wrong.

I am using Manjaro Linux with KDE desktop. Libreoffice 5.4.6.2 with English, Russian, Lithuanian, German and Swedish languages support installed.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-04-26 12:19:23 +0200

ajlittoz gravatar image

This may be an effect of AutoCorrection.

Check Tools>AutoCorrect>AutoCorrect Options, tab Language Options. This is where single and double quotes replacement are set.

To disable it, just uncheck the tick box.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Oh,sorry, forgot to mention, I already made these changes, I just don't like that this ix default behavior. Can anyone tell me why it is set like this?

Chelobaka gravatar imageChelobaka ( 2018-04-26 14:34:15 +0200 )edit

I'm no developer, I can't tell. Single and double quotes are really different signs and must not be interchanged. There is a good reason in some locales to transform ASCII single/double quotes into typographical quotation delimiters (with contextual left and right shapes), for instance in German and French. But that's the first time I hear of auto single to double.

ajlittoz gravatar imageajlittoz ( 2018-04-26 18:07:23 +0200 )edit

To make sure AutoCorrect is not the cause, uncheck Use replacement table in Tools>AutoCorrect>AutoCorrect Options, tab Options (this is a different tab) and try again.

If it no longer replaces, find the relevant entry in the replacement table and delete it.

ajlittoz gravatar imageajlittoz ( 2018-04-26 18:09:48 +0200 )edit

No, this is not the cause. first solution was right. I turned off single quote interchange. It just shouldn't be turned on by default (at least not for Russian text), on my opinion. But I don't know who and when made it by default and why, so, is there someone, who can answer this question? Why? Who uses this, for what?

Chelobaka gravatar imageChelobaka ( 2018-04-26 19:44:51 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-26 11:17:46 +0200

Seen: 483 times

Last updated: Apr 26 '18