Ask Your Question
2

How to see both doc and odt files in Libre writer?

asked 2018-05-06 20:53:33 +0200

Raptor88 gravatar image

updated 2018-05-10 09:11:09 +0200

I'm converting to Libre Office from MS Office 2000. I have a lot of MS word .doc files and Excel .xls files.

When I'm in Libre Writer and click open file, I can see both .doc and .odt files which is great. I like this!

BUT, when I'm in Writer and click "save as" to save a file, although my default is set to .odt files I want to see the .doc files too. I do want to save all files from now on in the .odt format but I want to see the .doc files in the "save as" dialog so I can reference my past .doc file names.

Is there an option in Writer that can do this? If not, is there an add on that can do this?

==============

5/9/18 Update: image description

As shown in the image above, my version of Libre Writer 5.3.4.2(x64), the save as dialog does not have an "all format" option. Wonder why yours does and mine doesn't?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
3

answered 2018-05-10 10:13:19 +0200

Infinite flexibility is bad. Everyone may invent some workflow that fits one's wishes, and which requires one little tweak into any used software. But using and supporting a software with ever-growing list of options that create amusing combinations becomes nightmare. Looking at tdf#102515, I anticipate much more (inexperienced!) users suffering from unexpected strange problems, then satisfied experienced users that get one less thing to think of.

Having said that:

  1. Windows Save As dialog shows you available file names that begin with characters you type into the name field.
  2. If you enter *.* into the name field, and press Enter, the dialog would list all available files, after which you may replace the *.* with whatever you need.
edit flag offensive delete link more
1

answered 2018-05-06 22:42:33 +0200

PaulaO gravatar image

updated 2018-05-07 13:16:17 +0200

David gravatar image

Select "Save as". Use the drop down menu for the "save as type" Select .doc It will then list the .doc files within that folder.

I use an extension called Multi Format Save. It allows me to pick which formats to save the file in:

  • odt
  • doc
  • docx
  • pdf
  • rtf

Because I must share documents with others at times, this allows me to make sure the doc file is as up to date as the odt

edit flag offensive delete link more

Comments

Hi PaulaO,

Thank you for your response. I have tried selecting .doc files from the "save as" drop down list and it does show the .doc files but then I can't see the .odt files in the folder. Plus then I have to select .odt again to save the document in the .odt format which I always want to do now and in the future.

When you use Multi Format Save, does it show the existing .doc and .odt files together?

Raptor88 gravatar imageRaptor88 ( 2018-05-08 03:23:04 +0200 )edit
0

answered 2018-05-07 07:58:53 +0200

ajlittoz gravatar image

updated 2018-05-08 10:54:20 +0200

The Save as dialog has a drop down menu below the file list. In this menu, select All formats. This will display several file types (the list of which is available is you develop the list of File types by hitting the small triangle).

Screenshot taken with 5.3.7.2:

Save As dialog

The drop down menu is above the Cancel and Save buttons. It is also used to preset the file type (if it is not All formats, in which case you must explicitly give the extension).

edit flag offensive delete link more

Comments

Hi ajlittoz, In my version of Libre Writer 5.3.4.2 (x64), I click FILE > SAVE AS. In the "Save as" dialog I click the drop down arrow head for "Save as type:" The drop down lists many different file types but it doesn't have an "All formats" option. What am I missing?

Raptor88 gravatar imageRaptor88 ( 2018-05-08 03:31:45 +0200 )edit

See my update with screenshot (intentionally blurred).

ajlittoz gravatar imageajlittoz ( 2018-05-08 10:55:12 +0200 )edit

I added an image to my original post as "5/9/18 Update". No "All format" option in my version of Writer. BTW, in that "Test" folder, I have a .doc file which does not show up since the save as file type is .odt.

Raptor88 gravatar imageRaptor88 ( 2018-05-10 09:08:44 +0200 )edit
0

answered 2018-05-10 09:24:15 +0200

David gravatar image

@Raptor88 - Please visit this bug report on the Document Foundation / LibreOffice issue tracker: fdo#102515 = "Save As dialog missing "All Formats" entry in file format drop down list [Windows]"

If that matches your experience, it would be worth adding your details there. If it is bug (and not a "feature"!), that issue list is the way to deal with it. Hope this helps.

edit flag offensive delete link more

Comments

Hi David, Thanks for your info. From the link you posted, it appears that the "All format" option shows in Linux versions of Writer but not in the Windows versions. The "bug" was reported in 2016 and apparently has not been corrected as of May 2018 so I guess the Libre Writer programmers do not consider it worthy of correction.

Oh well, at least now I know why my windows version of Writer does not have the "All formats" option. Will just have to live with it I guess.

Thanks again, Raptor88

Raptor88 gravatar imageRaptor88 ( 2018-05-10 10:02:33 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-06 20:53:33 +0200

Seen: 258 times

Last updated: May 10 '18