Ask Your Question

libreoffice online GET request client address DENY [closed]

asked 2018-05-10 08:01:25 +0200

Safir gravatar image

updated 2018-05-18 08:38:14 +0200

Hello, I use Libreoffice Online in docker containers. I have 4 containers each runs loolwsd. I added a loolwsd parameter to loleaflet and lool requests. It works fine. But when I want to print the document or download as pdf(or any other type), it does not work. The error in log is:

*[ websrv_poll ] ERR  client address DENY:| wsd/LOOLWSD.cpp:1828*

Download as PDF HTTP GET Request:


Response is :

HTTP/1.1 403
Server: nginx/1.10.3 (Ubuntu)
Date: Thu, 10 May 2018 05:53:25 GMT
Content-Length: 0
Connection: keep-alive
User-Agent: LOOLWSD HTTP Agent master..


I found it is because below commit was merged:

It filters POST requests but whatever I wrote in the loolwsd.xml at section such as "allow all reg patttern", it did not work.

SOLUTION: I found the solution here : patch

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Safir
close date 2018-05-18 13:28:44.523830

1 Answer

Sort by » oldest newest most voted

answered 2018-05-16 14:25:50 +0200

Please try again - we believe that this was addressed in this commit.

edit flag offensive delete link more


Thanks for the answer. I found the solution with this patch . It solved it. The files does not match: wsd/LOOLWSD.cpp and loolwsd.xml . loolwsd.xml has config: but in the code it is only .

Safir gravatar imageSafir ( 2018-05-18 08:37:04 +0200 )edit

Question Tools

1 follower


Asked: 2018-05-10 08:01:25 +0200

Seen: 653 times

Last updated: May 18 '18