Ask Your Question
0

Writer: Why does libre office insist on font in table?

asked 2018-05-12 20:04:07 +0200

Macnerd gravatar image

updated 2018-05-12 21:23:13 +0200

LibreTraining gravatar image

I've set the default font to Menlo. Every time I insert a table, libre office insists on liberation serif font. I have to keep selecting the table & changing the font. It drives me crazy. I've looked at the preferences & I see no way to change the font for the table to a default font. Why does the table insist on liberation serif & how do I change to default to Menlo or whatever I choose as the default font?

edit retag flag offensive close merge delete

Comments

I've set the default font to Menlo.

How?

gabix gravatar imagegabix ( 2018-05-12 20:40:29 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2018-05-12 21:09:13 +0200

Regina gravatar image

The paragraphs in a table have got the paragraph style "Table Contents" and "Table Heading", which is derived from "Table Contents". The style "Table Contents" has got its on font setting. If you want that the style "Table Contents" inherits the font from the style "Default", then you need to remove its own setting. Right-click "Table Contents" in Style&Formatting, part Paragraph styles, and click on item "Modify". Open tab "Font" and click on button "Standard". That should remove the own font setting, so that the inherited font is used. Be aware, that changing styles is a per document setting.

In case you use one of the predefined table style templates, the paragraph font setting is included in the table style template and applied to the table as direct formatting. So you first need to remove the direct setting. To do this, select the item "Clear Formatting" from the paragraph style drop-down-list in the Formatting-toolbar. Then the table will follow the settings in styles "Table Contents" and "Table Heading".

If you want to get your settings for other documents too, then you can make a document template from a document, where you have changed the style settings. Or you mark such a table (from end of paragraph before table to start of paragraph after table) and make an AutoText from it.

If you want to have a different default font for your tables than you have set as "Default" for the entire document, then you do the same steps, but do not click "Standard" but choose the font you want from the drop-down list.

I have tested it in LO 6.0.4. It might be, that you need to update to that version.

edit flag offensive delete link more
0

answered 2018-05-17 16:41:42 +0200

Macnerd gravatar image

OK, I'm keeping my fingers crossed!

Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-12 20:04:07 +0200

Seen: 48 times

Last updated: May 17