Ask Your Question
0

Can't type in save dialog, keypresses repeating

asked 2018-05-18 14:57:25 +0100

natgwil gravatar image

I am using LibreOffice Version: 6.0.3.2 on Kubuntu 18.04. I can't type in the save dialog, filename box. If I press any key on my keyboard just once, the box fills with repeated characters. (For example, if I press "a" the box fills with "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa...") If I press backspace just once to delete one character, it deletes everything. It's as if the keys are sticking. And yet there is nothing wrong with the keyboard when typing in the document, or indeed right now in this form. The problem means that I can't save anything, except with the default title "Untitled 1" etc. This is not happening in any other apps.

edit retag flag offensive close merge delete

Comments

I'm having exactly the same problem. Which operative system are you using? If it's a linux flavor, which desktop? I'm using Ubuntu 18.04 + KDE-Plasma.

dc740 gravatar imagedc740 ( 2018-05-28 14:58:40 +0100 )edit

Same here. Extremely annoying, all but disqualifying, and certainly can't recommend LibreOffice to any clients while it's doing this. It was also like this in 5.something.

Version: 6.0.3.2 Build ID: 1:6.0.3-0ubuntu1 CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde4; Locale: en-US (en_US.UTF-8); Calc: group

bearpaw8 gravatar imagebearpaw8 ( 2018-09-22 07:26:27 +0100 )edit

I have the same behavior since two weeks. Also Ubuntu 18.04 + KDE-Plasma. Only way around is to write the file name somewhere, then to copy paste.

tomtom8003 gravatar imagetomtom8003 ( 2019-04-18 09:23:29 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-18 09:39:22 +0100

updated 2019-05-27 20:07:42 +0100

Two work around found:

A.) Change the dialogs Simply change the save dialog and use LibreOffice Dialogs. Go to Tools - Options - General and check Use LibreOffice Dialogs

B.) Delete the field before typing 1. disable automatic file extension (bottom left in save dialog) 2. select the whole file name with the mouse, e.g. Untitled, or on Save As whatever you have 3. delete it 4. type the new file name in the field Clrt-X and Ctrl-V works also

Don't use the KDE "x". It won't work. And if this solution stops working, logout an login again.

Annoying. Please fix.

edit flag offensive delete link more

Comments

If you have some reproducible steps (as hinted by "disable automatic file extension"), please file a bug report. Otherwise, it's not reported to developers.

And by the way: what is your version? 6.0 (as in the question) is EOLed; is it reproducible with 6.2?

Mike Kaganski gravatar imageMike Kaganski ( 2019-04-18 09:49:12 +0100 )edit

Found better solution. Simply change the save dialog and use LibreOffice Dialogs. Go to Tools - Options - General - Use LibreOffice Dialogs. @Mike Thank you! I have 6.0.7.3 from Ubuntu 18.04. Will upgrade, and file the bug if still present.

tomtom8003 gravatar imagetomtom8003 ( 2019-05-27 20:03:47 +0100 )edit
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2018-05-18 14:57:25 +0100

Seen: 216 times

Last updated: May 27