Ask Your Question
0

LibreOffice Calc Columns/Rows formats

asked 2018-05-22 21:00:05 +0200

DanGzzR gravatar image

updated 2018-05-23 10:36:08 +0200

Lupp gravatar image

Several times a day, I receive libreoffice Calc archives that I'll use at work.

Many of them have a format that I modify manually 10, 15 or 20 times a day.

I'm trying to see if there's any way to simplify this task as it's repetitive and I'd like to reduce the time that this task takes away from me,

All sheets are applied the following format: Rows 1-5 remain the same. Row 6 is empty an unused. Columns A-P are used as follows: All columns except C, D, G and P are hidden, as the information on these columns is the only information I will use.

I always assign the following column width manually: C: 0.23 " D: 1.53 " G: 1.52 " P: 1.70 "

The only "shortcut" I've found is selecting several sheets at once and the format will be passed on to all the selected sheets. However many times there are archives with only 1 sheet or the archives are received at different hours a day

Any suggestion or comment is more than welcome.

Edit1 by @Lupp roughly quoting the comment by @DanGzzR on my (Lupp's) answer:

Still one thing: If the source the formats were copied from contains hidden columns (and/or rows), the target where the formats got pasted to ('Special...') does not regard this setting.
In short: The 'Hidden' property is not copied.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-05-22 21:54:27 +0200

Lupp gravatar image

updated 2018-05-23 10:43:53 +0200

I woul suggest you stiudy this thread of the forum.openoffioce.org/en. Everything there also applies to LibreOffice. 

You may then edit your question here to emphasize what you were missing there.

Edit1 concerning the (first) comment by @DanGzzR below (also quoted by me roughly editing the OQ):

Yes. The property of columns/rows to be hidden (internal representation: .IsVisible = False) is not treated as a format property.You may regard this a bug and file a report about it to bugs.documentfoundation.org.

Currently I don't know remedy except by applying user code.

edit flag offensive delete link more

Comments

I think this was pretty much it, made a template and applied the format to the other Archives I needed to use. There's still only 1 thing, when I copy the format column A is hidden, therefore when I paste the format from the template to any other archive, column A will not be hidden.

DanGzzR gravatar imageDanGzzR ( 2018-05-22 23:46:03 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-22 21:00:05 +0200

Seen: 140 times

Last updated: May 23 '18