Ask Your Question
0

Uncheck same content on first page doesn't work

asked 2018-05-24 16:26:38 +0100

Stackrat gravatar image

I just want to omit a normal header from the first page of a document. I realize I can do this with templates and styles but the very basic issue shouldn't really require that. I go to Format > Page > Header. There's a checked box to the left of "Same content on first page." I uncheck that box and click on "Apply." I expect the header to disappear from the first page but it doesn't. Why?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-05-24 17:21:06 +0100

ajlittoz gravatar image

updated 2018-05-25 11:58:46 +0100

When you uncheck Same content on first page after initial styling (i.e. you change your mind afterwards), LO Writer separates your page style into two related sub-styles. These substyles are clones of the initial page style, meaning that header text is copied into the "child" styles.

As a consequence both headers are now independent from each other, but as a fail-safe measure, LO Writer copied (as mentioned above) your initial header in both sub-styles, not knowing which one you want to change or erase. This avoids you retyping the header in case Writer made a wrong decision.

Just erase the unneeded header. It won't affect the other one.

Addendum 2018-05-25

The Same content … check boxes are only a convenience to spare you the pain of creating related page styles for the first, left and right pages of your document part. They keep the base page style and fork header and footer allowing to have 3 variants of them.

The advantage is the guarantee that general page settings (margins, background, …) are the same because there is a single page style.

Drawbacks are consequences of this simplification. You have less versatility in page lay-out compared to the 3-pagestyles configuration. An important one is the impossibility to insert another page style (such as a landscape page in an otherwise portrait document) without restarting the sequence at first page variant, as if there were a chapter change.

IMHO, this is a good shortcut for one-shot or "instant" document, but you should prefer the full 3-pagestyles feature with Next Style link in the Organizer tab for more elaborate documents.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
0

answered 2018-05-24 16:58:26 +0100

kompilainenn gravatar image

Because you should apply page style "First page" to first page before uncheck that box

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-24 16:26:38 +0100

Seen: 132 times

Last updated: May 25 '18