Ask Your Question
2

Mail Merge Skipping Labels? [closed]

asked 2013-04-02 18:34:57 +0100

Brendon gravatar image

updated 2013-04-02 18:35:19 +0100

I have a database set up as a long list of names and addresses - basically a mailing list. I noticed when I printed 4 pages of labels (directly from a Query), that I was short a couple labels.

(I set up a Libre text document with the template for Avery 5160 Address labels, 30 per page)

I eventually found out that each missing label was the 31st, 61st, and 91st label in the list - basically skipping a label every time it starts a new page of labels. I've gone through nearly all of the settings and nothing seems to reverse this.

I hope I am explaining this clearly - it's been driving me nuts this week.

Could this be a page-break problem? I've never changed any page break settings, however.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-19 22:32:03.776109

4 Answers

Sort by » oldest newest most voted
2

answered 2013-04-03 00:41:24 +0100

JohnD gravatar image

updated 2013-04-03 00:42:20 +0100

I use that same format for address labels and have not experienced any problem (yeah - that's not helping to solve your problem is it? :))

It almost sounds like the last label on then page has an extra "Next Record" field. You might want to check that by looking at the form with field names displayed (cntrl-F9).

edit flag offensive delete link more

Comments

That did the trick. I had an extra "Next Record" on the last label. Thanks a million, JohnD! :)

Brendon gravatar imageBrendon ( 2013-04-03 01:04:44 +0100 )edit
1

answered 2015-03-18 21:35:37 +0100

Mr. Slippery gravatar image

I just experienced exactly this problem.

I have a large spreadsheet of names and addresses; a mailing list. I recently did a mailing in which I printed four records per letter-size page, and cut the page into quarters for post cards. Actually I saved the mail-merge output to a file, and then printed from the file.

It was only later I realized the file created by the mail-merge had skipped every fifth record. Since I have only four records per page, it appears this is exactly the same problem described by the OP.

I followed the recommendation of examining the template to see if there was an extra "next record" field, but there is not. All four field-slots on the page are identical.

I used to do a lot of mail-merge with OpenOffice several years ago, but this is the first time I can remember using LibreOffice. The process doesn't appear to be any different. What I'm saying is, I don't think I did anything odd which might have caused such a problem.

As it stands, I failed to mail out a fifth of my list. I can single out the ones who didn't get mailed, pull them into a new list, and go again. But I'll probably be missing a fifth of those as well, which is ridiculous, right? :-)

Anyone have any suggestions? Thanks.

edit flag offensive delete link more
0

answered 2013-04-02 19:46:18 +0100

w_whalley gravatar image

I can't reproduce on LO 3.5.4 (linux) or 4.0.1 (windows), however I am printing the labels to a file, not directly to a printer. Does that make a difference for you?

edit flag offensive delete link more

Comments

Thanks for the quick reply. It is fixed now! I simply had an extra "Next Record" on the last label.

Brendon gravatar imageBrendon ( 2013-04-03 01:05:29 +0100 )edit
0

answered 2015-04-08 10:11:06 +0100

I experienced the same problem of missing every first record on the merged labels. After reading various suggestions, I figured that the last cell of the label document which you set up for mail merge should not have the code <<next record="">> at all. If you do this, all records are merged correctly. Alternatively, if you make enough pages (or labels) to cover all records before merging, then all records will show. I think that the first option is better.

edit flag offensive delete link more

Comments

this is the only solution that worked for me. thank you soooo much!!!

d13vsk gravatar imaged13vsk ( 2015-12-09 15:18:53 +0100 )edit

Question Tools

Stats

Asked: 2013-04-02 18:34:57 +0100

Seen: 13,443 times

Last updated: Apr 08 '15