Ask Your Question

Significant lag, frequent crashes in Ubuntu 18.04 [closed]

asked 2018-05-26 00:49:24 +0100

Cruiser13 gravatar image

updated 2020-07-25 19:42:48 +0100

Alex Kemp gravatar image

Recently updated to Ubuntu 18.04, which included an upgrade to LibreOffice I'm experiencing significant lag for operations including opening a new document, saving a document, inserting a comment, and changing page view. Typing itself typically works fine, but if I type during the lag there is a delay before the typing is registered, and then it registers the keystrokes seemingly at random rather than in the order I typed them, so I get gibberishy anagrams of the words I actually typed. Lately the lag has been lasting longer, and more and more frequently LibreOffice becomes unresponsive and I have to force quit.

I chiefly use Writer and Calc, and issue occurs in both.

I have tried rebooting, uninstalling/reinstalling, installing LibreOffice from the Ubuntu software center, and downgrading to Problem persists regardless.

No other programs are behaving oddly. This problem did not emerge immediately upon updating to Ubuntu 18.04, but my best guess is it's interacting negatively with something that wasn't there before...I just don't have any idea what.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-25 19:43:40.924028

2 Answers

Sort by » oldest newest most voted

answered 2018-05-27 21:19:14 +0100

joham34 gravatar image

I am having exactly the same problem too, after clean installing ubuntu 18.04 . Same pc, dual boot, ubuntu 16.04 with with , libreoffice is fast. I tried to increase memory from tools -> options -> advanced and then searching for cache but didn't help Any ideas?

edit flag offensive delete link more


Well, this doesn't necessarily count as a solution, but I found that by installing Kubuntu the problem was solved. The Kubuntu installation will also include LibreOffice, so it makes sense to uninstall your existing LibreOffice first. For me, Kubuntu's version of LibreOffice worked perfectly, even if I did not use the Kubuntu's Plasma desktop environment.

Cruiser13 gravatar imageCruiser13 ( 2018-05-30 22:36:00 +0100 )edit

answered 2018-07-19 14:05:08 +0100

desgua gravatar image

Going to Tools > Options > Libreoffice Writer > View and disablying "smooth scroll" made Libreoffice runs much faster for me.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-05-26 00:49:24 +0100

Seen: 4,238 times

Last updated: Jul 19 '18