Ask Your Question
0

How to format bibliography anchor

asked 2018-05-27 13:10:56 +0100

mirodin gravatar image

updated 2018-05-29 12:33:39 +0100

Hey guys,

I was wondering if it is possible to remove the brackets from a bibliography anchor. For example I have a text in which I insert a footnote. The footnote is a entry from my bibliography but that entry is enclosed by brackets like this:

[Smith] 33, 34

How do I remove those brackets around "Smith"? My prof does not allow them in the footnotes :(

Thanks for your help, mirodin

EDIT: 2018-05-28

Well I think my explanation was not clear as to what I mean. Maybe anchor is not even the right term, but I do not know how to name it instead :(

For example:

I have a text where I insert a footnote by Insert > Footnote which creates say footnote 6. At the bottom of the page next to 6 I enter the informations for this footnote by Insert > Bibliography entry and selecting the book I want i.e. the one from Smith. This inserts the said [Smith] next to the footnote and I will enter the page number/paragraph/whatever. In my example above this was [Smith] 33, 34, which would tell my prof: Look at Smith's book in the paragraphs 33 and 34.

I need LO to display at the bottom of the page 6 Smith 33, 34 rather than 6 [Smith] 33, 34.

I hope this helps clearing things up, thanks for your help anyways :)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-05-27 14:30:59 +0100

ajlittoz gravatar image

updated 2018-05-28 23:04:49 +0100

What are your numbers (33, 34)? A bibliography anchor with brackets like [Smith] is already some kind of pointer to the bibliography table. Listing them in a footnote is overkill (note anchor + biblio anchor) unless the rest of the note is an important comment or extra information. Brackets are an internationally agreed convention to distinguish biblio entries.

That said, if you really want to remove the brackets, you do it when you generate the bibliography table.

At the location where the biblio shoud appear, Insert>Table of Contents & Index>Table of Contents, Index or Bibliography.

Select Bibliography from Type drop-down menu. The dialog will be adapted to bibliography and a Brackets drop-down menu will appear. Select None. You're done.

In case you already inserted your bibliography, right-click in it, choose Edit Style and proceed as above.

EDIT 2018-05-28

My answer above remains valid after your clarification. You can remove the brackets only when generating the bibliography table. If the specification is such that no bibliography should appear in the document, insert it first in oder to be able to format the bibliography anchor, then right-click in the biblio table and choose Delete Index/Table. The table is erased but the format stays as it was last set.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

I did not mean to change the apperance of the biblio index, see my explanation above.

mirodin gravatar imagemirodin ( 2018-05-28 22:43:19 +0100 )edit

That it was, thank you for your patience :)

mirodin gravatar imagemirodin ( 2018-05-29 12:35:46 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-27 13:10:56 +0100

Seen: 49 times

Last updated: May 29 '18