Ask Your Question
1

Trouble setting custom border of image

asked 2018-05-30 00:37:07 +0200

us2137 gravatar image

updated 2018-06-13 20:34:03 +0200

Hi everyone,

I'm having a problem setting custom border of an image in Writer document. No matter what style I choose, I always get default black border. Does anyone have a clue why is it so? I set the border right-clicking on an image, going to borders tab, setting there and clicking 'OK'.

Version of LibreOffice is 6.0.3.2 (x64), but this was updated from a previous version (6.0.something) due to this problem, but didn't help. OS is Windows 10 Home x64. Binary comes from official LibreOffice image, and Java is up to date, if that matters. I'd appreciate any hints.

Edit: Here is a screenshot of the window. I'm sorry it's in high-contrast and non-English, but it should be clear. (right click and "show image" to zoom it in)

image description

Edit 2: So after switching to default Windows theme (non high-contrast) it worked fine! So this really seems like Windows high-contrast issue. Another one I've found is that if you (in high-contrast) set border width to eg. 0.5p, save file and open it again - the border gets wider to 1.5p, and if you do it once again - to 2.5p. Please find screens below (both screens of the very same file, only after switching theme): image description image description

edit retag flag offensive close merge delete

Comments

Only to be clear, you do: Right-click image > Properties > tab Borders. Set style, width and color in section Line, select which border part is to be styled in section Line Arrangement. Is the preview in part User-defined: correct? OK. Is the border at the image correct?

Regina gravatar imageRegina ( 2018-05-30 01:22:30 +0200 )edit

The first part is correct. Then I see, that the preview does not update and stays the same. And so the image border after 'OK' is kind of 'default black'.

us2137 gravatar imageus2137 ( 2018-05-30 09:37:12 +0200 )edit

Do you really have selected the border parts, which you want to change? There should be little black triangles in the preview. Perhaps you attach a screenshot of the dialog page?

Regina gravatar imageRegina ( 2018-05-30 12:36:45 +0200 )edit

Yes, they are set. I attached a screenshot in the question post. I guess if I there was no borders part set there would be no border at all. And here even the thickness changes on preview, but colour and style stays black solid line.

us2137 gravatar imageus2137 ( 2018-05-31 22:17:49 +0200 )edit

Can you please switch to a default theme? I suspect the high-contrast theme is the reason. And if it is the reason, then it is a bug and you should write a bug report.

Regina gravatar imageRegina ( 2018-05-31 23:55:20 +0200 )edit

Hi @Regina, apologies for such a late reply - in fact it's my aunt's PC and we had troubles in communication. I've managed to get remote desktop and after some testing I think it's a bug. Could you advise if it really is and if so, where to report it? Thank you in advance.

us2137 gravatar imageus2137 ( 2018-06-13 20:35:35 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-06-14 12:12:29 +0200

Regina gravatar image

That is a bug. You could report bugs at https://bugs.documentfoundation.org. But I have done it already for you. https://bugs.documentfoundation.org/s...

edit flag offensive delete link more

Comments

Thank you for your support and time. I'll be checking out the bug status.

us2137 gravatar imageus2137 ( 2018-06-14 20:21:44 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-30 00:37:07 +0200

Seen: 29 times

Last updated: Jun 14