Ask Your Question
0

Mysql Connector Extension 4-3 no longer works with current LibreOffice

asked 2018-06-04 10:08:19 +0100

KrpaN gravatar image

After upgrading the OS from Suse Leap 42.3 to Leap 15.0 mysql/mariadb database cannot be accessed any more. The error message reads as follows: The connection to the data source could not be established. SQL Status: 08001 Unable to load the libmysqlcppconn.so library. So far I used a native mysql connector mysql-connector-linux_4-3_x86_64.oxt without any problems. I tried mariadb JDBC driver and it worked fine. However, I sticked to the native driver since all my templates are populated with plurality of database fields, and it would be a real nightmare to make everything from the scratch. I also tried LO 5.4.7 and LO 6.1 beta. However, the result was the same; no connection to the database. I got the mysql connector from the LO extension site. Sadly, it looks like the mysql/mariadb connector is not maintained any more. So what do you suggest me to do. I really need this connection urgently.

edit retag flag offensive close merge delete

Comments

The msg is clear. .so file is either missing or is unusable. Have you tried this?

Xoristzatziki gravatar imageXoristzatziki ( 2018-06-07 08:24:54 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-07-19 16:01:26 +0100

trueriver gravatar image

The connectors have diverged since the fork.

You can either a) install both connectors to all your sites b) figure out which site needs which connector

(a) is fast and dirty (and you probably still need to select the right one somewhere)

(c) move every database to the same engine

My opinion:

(c) is the most professional way to go if you have admin rights on all servers but is most work because of migrating data

(b) might be the best compromise

(a) is the messiest but will get you going fastest

Your choice ;)

edit flag offensive delete link more
0

answered 2018-06-04 15:33:40 +0100

Ratslinger gravatar image

Hello,

Try v1.2 connector found here -> MySQL Driver for Apache OpenOffice.

Been using this for years on Ubuntu based systems & currently working on LO v6.0.4.

If this answers your question please tick the ✔ (upper left area of answer). It helps others to know there was an accepted answer.

edit flag offensive delete link more

Comments

I tried v1.2 in the past and it worked only for an extent. Some querries remain unanswered, I mean the result has been zero instead of some data. Right now, my LO is v6.0.4.2. Everything runs smoothly on the othe rmachine with Suse 42.2, LO 6.0.3.2 and mysql-connector-linux_4-3_x86_64. Therefore, either something is radically changed in LO since 6.0.4 or in Suse Leap since 15.0.

KrpaN gravatar imageKrpaN ( 2018-06-05 07:35:18 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-04 10:08:19 +0100

Seen: 319 times

Last updated: Jul 19 '18