Ask Your Question
1

Slow typing and high CPU usage after a certain point.

asked 2018-06-11 07:00:25 +0200

Shadow_Lucifer gravatar image

It's been a lot running problem with me for Using LO Writer. After a certain point in writing (about 70k characters), the program seems to be slowing down quite a lot, taking a few seconds to register the next typed words. I'm not sure if it's just an issue with my CPU or what, but it can be quite bothersome, as someone that uses the program for stories.

[I use 12 font size and Liberation Serif font, if that matters worth anything.]

Help would be greatly appreciated. Anyway for me not to have to keep creating new files after 70k would be great.

edit retag flag offensive close merge delete

Comments

Do you happen to make use of tables in your writing? When I was doing some language-based work which was always done in tables, things could get very slow on my old Toshiba laptop....

David gravatar imageDavid ( 2018-06-12 16:11:21 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-06-11 09:22:19 +0200

user4657 gravatar image

updated 2018-06-16 12:49:53 +0200

There are a few things you could do to track down the problem:

  1. Try to reproduce the problem in a different environment, e.g.:
    • on another computer
    • in LO safe mode, as Lupp already suggested.
  2. Try to reproduce the problem on another computer.
  3. Install the latest version of LO and try to reproduce the problem using that version.
  4. Try to reproduce the problem in a clean environment, i.e.
    • in a clean profile, as suggested by Lupp, or
    • in a new, clean installation, for example in a virtual machine, or in a so-called Linux ”chroot“ environment
  5. Try to reproduce the problem in a new text document, not using any formatting or special characters. So simply create a new .odt file and type 70k alphabetical and/or numerical characters. Check if the problem occurres.

If all of the above tests lead to the same slowness, it's very likely you found a LO bug.

If the above tests reveal the problem to be device-specific (to be reproducible only on one computer), then I suggest you to track down the cause of the problem using resource monitoring tools. Try to observe what's happening when LO Writer gets slow. The specific tools you can use depends on your operating system. On Microsoft Windows systems you can use the Task Manager, the Resource Monitor and/or the Process Monitor.

edit flag offensive delete link more
1

answered 2018-06-12 10:20:38 +0200

Lupp gravatar image

updated 2018-06-12 10:38:27 +0200

User RoryOF from the well structured forum.openoffice.org pointed me to this thread and informed me of some ideas concerning a possible cause:
Quoting RoryOF: "This has the feel of a problem we run into on OO from time to time, where users terminate paragraphs using Shift Enter (a old habit from some earlier word processor) and reach the OO paragraph limit of 64k characters. I remember reading that this paragraph limit was extended in LO to 16million {In fact: 2^31-1=2147483647, the largest positive representable by a 32-bit integer; (Lupp)} characters, but it may be possible that the user who posted the above thread is using an older LO (pre-correction) and/or shift-Enter to terminate his paragraphs. Turning on /View /Non printing characters (wherever this is in LO) will speedily show the absence of Paragraph marks (the pilcrow - backwards P character)."
Rory is right concerning the raising of the limit of characters per paragraph. It was introduced in LibO with V4.3.

To enable viewing non-printing characters is always a good suggestion. (I would add: To do otherwise is a very bad idea.)

However, the mentioned limits are hard. Trying to exceed them should completely fail, not only slow down the application.
Therefor I would like to remind you of the fact that very strange issues may be caused by user profile corruption.

edit flag offensive delete link more

Comments

So the issue is just too many characters in a single paragraph...?

Also I'm running LibreOffice 5.4.7. I believe it's the latest LibreOffice 5 version.

I do have a bad habit of "Block Typing" as I call it, where I just type and type and never paragraph anything. Essentially everything is just one massive paragraph.

I loaded up one of my considerably large documents, 400k+ that was paragraphed and it was fine.

Could this issue just be fixed by me paragraphing my works instead of block typing?

Shadow_Lucifer gravatar imageShadow_Lucifer ( 2018-06-13 14:03:35 +0200 )edit

Quoting @Shadow_Lucifer: "So the issue is just too many characters in a single paragraph...?"
I did not fortify this suspection, but only passed it to you from a hint an experienced user posted elsewhere.
My actual suggestion is to try a reset user profile, or to run LibreOffice for a test in safe mode which will not touch your user profile at all.

Lupp gravatar imageLupp ( 2018-06-13 14:27:54 +0200 )edit

Now, I'm not gonna argue against testing in safe mode, but resetting my user profile would be a terrible mistake for me considering the extensive personal dictionary I have on LibreOffice.

If there is a way to back-up my personal files before the reset, I'd consider a reset. Otherwise, I'm not risking losing thousands and thousands of words I've added to my personal dictionary.

I know it's a suggestion to try to help fix my issue, but I want to have a backup should something go wrong with it.

Shadow_Lucifer gravatar imageShadow_Lucifer ( 2018-06-13 15:23:02 +0200 )edit

Never reset the user profile without making a backup of the current one. Since the "reset" is done by withdrawing the access via the stored name from LibO starter, simply rename the original user folder to user.2018-06-13.bck e.g. The above linked in wiki-page also warns you to not omit backuping.

Lupp gravatar imageLupp ( 2018-06-13 18:56:34 +0200 )edit

I have since backed up and reset my user profile, entered in safe mode, and the problem I'm having is still occurring. I don't believe it to be corruption in the user profile, but I'm no professional. Entering Safe Mode should have stopped/resolved the issues, however they did not.

Is there anything else to suggest to try to fix this, unless as I stated above previously, that a single paragraph is too long for what I'm doing.

Shadow_Lucifer gravatar imageShadow_Lucifer ( 2018-06-14 02:45:04 +0200 )edit

And it's probably also worth noting that I'm using LibreOffice on a Toshiba Sattelite. If that even matters at all.

Shadow_Lucifer gravatar imageShadow_Lucifer ( 2018-06-14 02:47:23 +0200 )edit

I'm not an expert in everything, and most likely not an expert in anything.
The group-name of your notebook is not of much use. Relevant information might be:
OperatingSystem, its version (supposedly Win V..).
Version of LibreOffice.
Size of RAM.
State of battery. (Some hardware slows down the processor if accu is low.)
Running applications and the memory used by them. (My Firefox e.g. currently uses 0.9 GiB.)
The CPU-load caused by other applications.
Speed of Swap.

Lupp gravatar imageLupp ( 2018-06-14 10:51:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-11 07:00:25 +0200

Seen: 166 times

Last updated: Jun 16