Ask Your Question

Impress 6 in ubuntu 18.04: video playback only as full screen

asked 2018-06-12 21:34:52 +0200

H Ford gravatar image

I am using Impress in ubuntu 18.04. When I embed a video and then put the presentation on slideshow, any slide with a video immediately starts playing the video fullscreen, rather than in the slide.

Based on googling through forums, I have been trying to make sure all gstreamer plugins are installed, but don't know if something is still missing. Or maybe it is something else entirely.

Any help would be appreciated!


Below are the results of $ dpkg -l | grep gstreamer

ii gir1.2-gstreamer-1.0 1.14.0-1 amd64 GObject introspection data for the GStreamer library

ii gstreamer1.0-alsa:amd64 1.14.0-2ubuntu1 amd64 GStreamer plugin for ALSA

ii gstreamer1.0-clutter-3.0:amd64 3.0.26-1 amd64 Clutter PLugin for GStreamer 1.0

ii gstreamer1.0-fluendo-mp3:amd64 0.10.32.debian-1 amd64 Fluendo mp3 decoder GStreamer 1.0 plugin

ii gstreamer1.0-gl:amd64 1.14.0-2ubuntu1 amd64 GStreamer plugins for GL

ii gstreamer1.0-libav:amd64 1.14.0-1 amd64 libav plugin for GStreamer

ii gstreamer1.0-packagekit 1.1.9-1ubuntu2 amd64 GStreamer plugin to install codecs using PackageKit

ii gstreamer1.0-plugins-bad:amd64 1.14.0-1ubuntu1 amd64 GStreamer plugins from the "bad" set

ii gstreamer1.0-plugins-base:amd64 1.14.0-2ubuntu1 amd64 GStreamer plugins from the "base" set

ii gstreamer1.0-plugins-base-apps 1.14.0-2ubuntu1 amd64 GStreamer helper programs from the "base" set

ii gstreamer1.0-plugins-good:amd64 1.14.0-1ubuntu1 amd64 GStreamer plugins from the "good" set

ii gstreamer1.0-plugins-ugly:amd64 1.14.0-1 amd64 GStreamer plugins from the "ugly" set

ii gstreamer1.0-pulseaudio:amd64 1.14.0-1ubuntu1 amd64 GStreamer plugin for PulseAudio

ii gstreamer1.0-tools 1.14.0-1 amd64 Tools for use with GStreamer

ii gstreamer1.0-vaapi:amd64 1.14.0-1 amd64 VA-API plugins for GStreamer

ii gstreamer1.0-x:amd64 1.14.0-2ubuntu1 amd64 GStreamer plugins for X11 and Pango

ii libgstreamer-gl1.0-0:amd64 1.14.0-2ubuntu1 amd64 GStreamer GL libraries

ii libgstreamer-plugins-bad1.0-0:amd64 1.14.0-1ubuntu1 amd64 GStreamer libraries from the "bad" set

ii libgstreamer-plugins-base1.0-0:amd64 1.14.0-2ubuntu1 amd64 GStreamer libraries from the "base" set

ii libgstreamer-plugins-good1.0-0:amd64 1.14.0-1ubuntu1 amd64 GStreamer development files for libraries from the "good" set

ii libgstreamer1.0-0:amd64 1.14.0-1 amd64 Core GStreamer libraries and elements

ii libreoffice-avmedia-backend-gstreamer 1:6.0.4~rc2-0ubuntu0.18.04.1 amd64 GStreamer backend for LibreOffice

edit retag flag offensive close merge delete


I can confirm I have the same problem with LibreOffice 6.0.3 on Ubuntu 18.04. This problem was not present with LIbreOffice 5.X on Ubuntu 16.04.

marius311 gravatar imagemarius311 ( 2018-06-14 11:05:11 +0200 )edit

I have the same issue. LibreOffice on Ubuntu 18.04. Also did not have this problem before the update.

vs18 gravatar imagevs18 ( 2018-08-25 02:28:49 +0200 )edit

I can confirm this problem using Linux Mint 19.1 and LO Even when one wants to re-scale the frame where the video is embedded in, a full screen is temporarily shown. The worst thing is that the full screen is shown both on the presentation-screen and on the computer-screen. In this way the notes and the buttons on the computer-screen are no longer visible/usable. I'm using back the work-around by embedding a reference into an image. Clicking on the image starts vlc.

PèreOrval gravatar imagePèreOrval ( 2018-08-25 11:46:23 +0200 )edit

3 Answers

Sort by » oldest newest most voted

answered 2018-09-27 16:26:03 +0200


I had the same problem, and others related to TexMath. I found the answer in this forum:

The problem seems to be with bugs in GTK3 interface. The solution is to go back to GTK2:

sudo apt-get remove libreoffice-gtk3

sudo apt-get install libreoffice-gtk2

That's it!

edit flag offensive delete link more


This worked for me, thanks!

jjgomez gravatar imagejjgomez ( 2018-10-24 14:22:45 +0200 )edit

this worked for me too, you're awesome!

avishek gravatar imageavishek ( 2019-02-19 03:12:05 +0200 )edit

also worked for me. Thank you.

fenixjose gravatar imagefenixjose ( 2019-08-09 17:43:21 +0200 )edit

answered 2018-09-11 01:41:20 +0200

Hi, I solved this on Ubuntu 18.04.

Based on bug report from red hat I think some functions/plugins necessary were moved around, so I just installed gstreamer plugins until I found the one that worked.

Easiest is sudo apt-get install gstreamer1.0-plugins-*

Most likely candidate is the GTK3 or QT5 packages, or one of the GTK/QT plugins.

Best, Richard.

edit flag offensive delete link more


Wow,that was my problem and solution. Gstreamer plugins... it now can embed videos without a problem. As Gifs are badly supported, I can now ffmpeg -i mygif -y out.webm and insert the video. Thanks a lot for that

metal3d gravatar imagemetal3d ( 2019-02-04 18:47:30 +0200 )edit

answered 2019-03-25 18:27:14 +0200

Hi. I solved it with: sudo apt install gstreamer1.0-gtk3 using Xubuntu 18.04

Greetings from Mendoza.

edit flag offensive delete link more


This is effectively the accepted answer. Although I lack sufficient karma to even upvote answers, this verifiably works and is substantially simpler than alternate approaches. Clearly, Debian and/or Ubuntu package maintainers should add gstreamer1.0-gtk3 as a mandatory dependency of the libreoffice-gtk3 package. Would someone who is not me mind submitting a Launchpad issue against this package? This ASCII art adequately summarizes my current feelings: ¯\_(ツ)_/¯

pietakio gravatar imagepietakio ( 2019-04-26 00:59:19 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-06-12 21:34:52 +0200

Seen: 1,831 times

Last updated: Mar 25