Ask Your Question
0

Can't select text language in Tools.Spelling&Grammar dialog

asked 2018-06-14 20:45:00 +0200

carnish gravatar image

updated 2018-06-14 20:46:59 +0200

Version: 5.2.7.2 Build ID: 1:5.2.7-1+deb9u4 CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; Locale: en-US (en_US.UTF-8); Calc: group

Spell libraries hunspell-en-gb and hunspell-en-us are installed + all aspell libraries.

Spell check does not find errors.

When I open the Tools/Spelling/ dialog, Writer runs spell check, and finds no errors (even though I have put errors).

In the The Text Language selection button says [None]. Options under the button are English UK and English US, each with a checkmark beside.

However when I choose either option, the field returns to None.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2018-06-14 23:31:22 +0200

floris v gravatar image

That's right. The language box merely displays the language assigned to the text under inspection. If Language is set to None, it means that you didn't assign a language to the text, in which case the spell checker ignores it and reports that no errors were found. So, stop the spell checker and inspect your document. Assign a language to the Default paragraph style (Font tab), then try the spell checker again. By the way, you can use the spell check as you type, which is mostly more useful.

edit flag offensive delete link more

Comments

Yes indeed. That's great. Another issue was that the document originated from a machine with microsoft fonts and this machine didn't have them so the Default style had no option for language. To install them, I enabled the 'non-free' repository in /etc/apt/sources.list, apt updated, and installed ttf-mscorefonts-installer. All is well.

carnish gravatar imagecarnish ( 2018-06-15 00:20:46 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-14 20:45:00 +0200

Seen: 36 times

Last updated: Jun 14