Ask Your Question
1

clearing some formatting without clearing other formatting

asked 2018-06-15 10:39:39 +0200

bphil__ gravatar image

I am trying to clear formatting on word converted documents. There are two cases I am having trouble with

  1. I am trying to remove explicit paragraph formatting from all footnotes so as to revert them to the style defined formatting. If I use find and replace with paragraph styles option (or "alternative find and replace dialog") to select all footnotes and then click on "Set Paragraph Style" in the toolbar and select "Clear formatting", all character formatting (like italics) is removed as well. (Also, if I try to just select a new paragraph formatting through the Format->Paragraph menu, italics are also removed).

  2. I was also trying to change certain character formatting without touching other character formatting. In this instance, I wanted to format all footnotes to Nimbus Roman 10pt, but selecting all footnotes as described under (1.) and changing the font type and size also removed all italics.

I've read various related questions, but could not glean a solution to my problems from them.

I am running LO 5.4.7.2 on Arch. Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-06-15 11:06:38 +0200

Lupp gravatar image

updated 2018-06-15 14:06:54 +0200

  1. If you want footnotes always to be in Italic, modify the respectve principal ParagraphStyle Footnote to the italic font. Clear direct formatting for all footnotes (with Ctrl+M e.g.) having FoundAll of them with F&R searching for Paragraph Styles = Footnote. (Not for specific attributes!)

  2. Do it for the Footnote style, not vor every piece of text formatted one or another way.

  3. Start using named styles (paragraphs / characters) wherever appropriate instead of direct formatting. In a professional looking text that's next to always.

  4. Do it for your templates. Make your most used template your 'Standard'. No 'Normal.dot'.

  5. Be glad to have abolished silly 'Word'.

Editing with respect to the comment below:
I don't feel sure if I understood everything. If I was not too bad:
Do it in some steps:

Define your Footnote Paragraphstyle as wanted (or leave it as it is).

Select anywhere one Italic word (exclude the spaces) in a footnote, choose Character Styles via the icon in Styles an Formatting, click New Style from Selection fill in the charStyleName (defaultPlusItalic e.g.) to the dialog you get.

Use F&R with Paragraph Styles, Find: Footnote, FindAll.
Keep the multiselection pending! (No hasty action!)

Change options for F&R now: Paragraph Styles off Current selection only on, click button Attributes, select (only!) Font posture, enter Italic behind Find:{I was wrong. Thanks to @phil__ !} FindAll. Assign the character style you created for Italics in footnotes to the new multiselection (doubleclick in Styles and Formats).

(If wanted:)
Do respectively for Bold or whatever attributes you also used in footnotes and want to keep.

(If necessary:)
F&R all footnotes again as described above and clear direct formatting once and for all from the multiselection (by Ctrl+M e.g).

Never use direct formatting again in sensitive contexts.

Be glad again. Learn that LibreOffice is much better than MS-Office. Or judge yourself.

Edit2:
A respective procedure should help with similar problems concerning different specialised paragraph styles lime heading styles, numbering styles, table contents ...

edit flag offensive delete link more

Comments

Thanks for your answer. I do not want all my footnote text to be in italics. There are words that are in italics and I need to preserve this formatting for these words. However, when I try to modify the formatting of my footnotes en masse, the italics are gone...

bphil__ gravatar imagebphil__ ( 2018-06-15 11:43:02 +0200 )edit

Excellent answer. The only thing that did not work the way you described it was the Step "Font posture, enter Italic behind Find:". Doing that, it came back with "search key not found". Simply selecting "Font posture" and clicking immediately on Find All, without specifying anything behind "Find:" did the trick though. In order to save my honor I also want to point out that these documents have not been created by me, so I have to deal with the direct formatting, unfortunately...

bphil__ gravatar imagebphil__ ( 2018-06-15 13:47:13 +0200 )edit

Quoting @bphil__: "...the Step "Font posture, enter Italic behind Find:"
Thanks!
You are right. I accessed some bits of bad RAM between my ears.
Hopefully you agree with my rectifying this in my answer now.
(No attack against your honor -or that of the original author- intended. Many user, mainly those coming from MS-Office, do lots of direct formatting. Concerning Calc we then get questions how to evaluate such attributes as data.)

Lupp gravatar imageLupp ( 2018-06-15 13:54:08 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-15 10:39:39 +0200

Seen: 165 times

Last updated: Jun 15 '18