Ask Your Question
0

Why do I always get transparency error when I export to PDF? [closed]

asked 2013-04-07 16:36:53 +0100

AndersB gravatar image

updated 2013-10-17 21:22:00 +0100

manj_k gravatar image

Trying to export a odt-document to a pdf file. I want to embed the fonts so I checked the PDF/A-1a box. But then I always get an error message box complaining about PDF/A-transparency. I tried removing potential problems and ended up with an empty document and still got the error box! The file is converted ok but because I want to batch convert loads of odt-files to pdf, the error message box is the only problem. LibreOffice 3.6 and 4.0 behaves in the same way.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-02 03:06:42.769846

Comments

I also have this question - what is the solution? I'm using os10.11.2 and LibreO 5.02

craig_S gravatar imagecraig_S ( 2015-12-17 14:21:22 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-06-06 03:46:24 +0100

oweng gravatar image

updated 2013-06-06 04:02:17 +0100

The OP does not mention which OS they are using or LO version. The basic problem here is the warning message about transparency, which appears to be a bug. Old closed bug fdo#40618 seems to be the same issue, however I am going to raise a new one (EDIT: fdo#65439) and let the developers sort out whether this is the same issue from back then or not.

As mentioned by @AndersB and @SKelem, for v4.0.3.3 no combination of settings under Tools > Options... > LibreOffice > Print will get rid of this message when exporting to PDF/A-1a. Even a new document containing a single character (e.g., "a") produces the warning so it is not apparently related to embedded images.

The statement, "I want to embed the fonts so I checked the PDF/A-1a box", makes no sense as a font subset will be embedded in any PDF exported from Writer.

edit flag offensive delete link more

Comments

The last sentence is probably because the OP has read about Word, as the only way to embed fonts there is to check PDF/A compliance.

lapo gravatar imagelapo ( 2015-10-11 11:41:36 +0100 )edit
0

answered 2013-06-06 02:27:11 +0100

SKelem gravatar image

In LibreOffice 4.0.3.3, turning the Printer Warnings settings ON for Transparency, gives a warning when at least one of your images (but they don't tell which one(s)) has transparency.

If you turn OFF the Printer Warnings for Transparency, then you STILL get a warning when at least one of your images (but they don't tell which one(s)) has transparency.

edit flag offensive delete link more
0

answered 2013-04-07 17:32:16 +0100

m.a.riosv gravatar image

There are options about print transparencies in:

Menu/Tools/Options/LIbreOffice/Print.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-07 16:36:53 +0100

Seen: 2,734 times

Last updated: Jun 06 '13