Ask Your Question
1

LibreOffice 6 on Ubuntu Linux, soffice.bin 100% cpu load

asked 2018-06-19 16:41:58 +0200

frankvw gravatar image

Hi all,

I'm running LO 6.0.3.2 on Ubuntu Linux 18.04. As with previous versions, the process soffice.bin frequently shows a persistent 100% CPU load, heating up the CPU and draining my laptop battery.

I usually have several documents open in Writer and Calc at the same time, on of which is rather large (185+ pages with about two dozen images). That might be related to the problem, however if LO is starved for memory I'd expect that to take the form of slowed response, increased swapping and the like, not a maxed out CPU load.

Old (and now apparently obsolete) forum posts suggest tweaking memory settings, which as far as I understand no longer applies. I can't find any other "tuning" options in LO, unless there's something under 'advanced' that I'm unaware of.

Suggestions, anyone?

// FvW

edit retag flag offensive close merge delete

Comments

Hi, Same issue here. The memory settings can be tweaked under 'advanced options', but apparently that's not recommended and probably unrelated to the issue (according to LO). Some posts said it's an issue with glib2, and deprecating solved the issue for some people.

Funny thing, I found out that the issue only happens when I open the odt version of my document, but not the docx.

uamoti gravatar imageuamoti ( 2018-07-12 12:48:10 +0200 )edit

same here but with 16.04.

hias gravatar imagehias ( 2018-07-17 13:57:49 +0200 )edit

Same issue with similar usage. Windows platform (Windows 7 x64). Libre Office version 6.0.6.2 (x64). I have also noticed that this happens more often when opening MS Office files.

CremionisD gravatar imageCremionisD ( 2018-09-25 11:43:07 +0200 )edit

I'm also finding libreoffice spreadsheets unusable due to this bug. It starts consuming 100% cpu and making certain actions take excruciating long. Last time this happened, it was when I tried to insert a column in a small spreadsheet. Also under Ubuntu 18.04 (mint mate 19.1).

hjs gravatar imagehjs ( 2019-01-03 06:29:41 +0200 )edit

CONFIRM OBSERVATION BY oamoti: I have a large document (114 pages, 33,000 words, 180,000 characters) with perhaps 80 images. When stored as an .odt file it opens slowly, saves very slowly, and consumes 100% of one of my eight cpu's (htop) when the document is open even if I am doing nothing. Following the observation above by uamoti, I saved it as a .docx file. It now opens very-quickly, saves quickly and no longer consumes much cpu. (UBUNTU 16.04; LO 6.0.6.2).

Rich VanMetter gravatar imageRich VanMetter ( 2019-03-21 03:26:52 +0200 )edit

Opening basically any .odt, no matter the size, is going to produce 100% load on a single CPU thread in Ubuntu 18.04.

MarkoF gravatar imageMarkoF ( 2019-05-27 11:50:04 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-09-29 00:03:16 +0200

updated 2019-09-29 00:05:08 +0200

SAVE ALL OPEN DOCS, THEN use pkill soffice.bin. Re-open libreoffice and let it recover your open docs.

See my full answer to this on Ask Libreoffice here: https://ask.libreoffice.org/en/questi... and on ServerFault here: https://serverfault.com/questions/953....

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

5 followers

Stats

Asked: 2018-06-19 16:41:58 +0200

Seen: 2,550 times

Last updated: Sep 29