Ask Your Question
0

problem reading xls file [closed]

asked 2013-04-08 12:02:42 +0200

mohamad gravatar image

updated 2013-04-08 12:03:32 +0200

I have a problem with my xls files . when I open them all the words and character are not readable . I mean they should be in persian or utf8 incoding but there is just lots of signs and characters that make no sense . I converted my file with zamzar online file converting to ods file type , then I was available to read the file and everything was fine . but for each file I can't convert it to ods . please help me out .

this is my file : https://www.dropbox.com/s/nbi8nii1iweu4ey/FileName.xls

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-29 15:52:45.760894

2 Answers

Sort by » oldest newest most voted
1

answered 2013-04-08 13:10:15 +0200

Pedro gravatar image

The problem is that your files (or at least the sample provided) are not true XLS files (and this confuses LibreOffice). They are HMTL files with a wrong extension.

The easiest way to solve this is to 1) rename the files to .html; 2) Open with LO (it will open in Writer); 3) select the whole table (Table, Select, Table); 4) Change font to Tahoma (at least in my PC some characters were still showing as empty squares if I didn't change the font) 5) Copy and Paste in a New ODS spreadsheet.

Hope this helps ;)

edit flag offensive delete link more

Comments

Disregard my comment below, it is the same as that suggested by @Pedro.

oweng gravatar imageoweng ( 2013-04-08 13:25:56 +0200 )edit
0

answered 2013-04-08 13:24:20 +0200

oweng gravatar image

Your file is a HTML table and not an XLS file. These types of files are often generated by retail software and given an XLS extension in order to allow automatic file association with office software. I am not sure how your file was generated, but like so many of these types of files, it contains very poorly formatted HTML e.g., there is no !DOCTYPE declaration to tell the interpreter the data is UTF-8 encoded, and no basic structural elements such as <html>, <head>, or <body>.

The easiest way to get your data is:

  1. Change the file extension from XLS to HTML;
  2. Open the HTML file with Writer;
  3. Select the entire table;
  4. Edit > Copy;
  5. Create a new spreadsheet;
  6. Edit > Paste.
edit flag offensive delete link more

Comments

Thank you for this. I have had problems opening "Excel Format" bank transaction downloaded from Santander. Santander's internet support has been unable to help. The Santander files download with an XLS extension but Excel 2010 gives errors when opening though telling Excel to ignore eventually gets them open see http://goo.gl/m91BW3 This issue is also discussed for LibreOffice Calc see http://goo.gl/gOIOqG and this page has a solution but your solution seems clearer. Thanks again.

HimAgainAgain gravatar imageHimAgainAgain ( 2015-04-17 13:27:40 +0200 )edit

Question Tools

Stats

Asked: 2013-04-08 12:02:42 +0200

Seen: 3,120 times

Last updated: Apr 08 '13