Ask Your Question
0

I have to use curly quotes in my work. How do I do that?

asked 2018-06-28 12:25:01 +0100

hirondelle gravatar image

I've just moved 240 pages of a novel from the word processor I was using into Libre Office. I like the latter very much. But I can't find out how to use what are often known as 'curly' quotes. Without being able to do that, I'm going to have to stay with my present WP. Surely there is a way of doing this??

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2018-06-28 12:53:54 +0100

floris v gravatar image

Getting curly quotes is controlled in the autocorrect facility. In Tools - Autocorrect - Options for Autocorrect, Localised options tab you can select the curly quotes to be used, Writer will then automatically replace quotes by the corresponding curly ones.

edit flag offensive delete link more

Comments

Quoting @floris v: "Writer will then automatically replace quotes by the corresponding curly ones."
Also for the 240 pages the OQ was talking of?
From my experience I would expect the replacement only for subsequent typing.

Lupp gravatar imageLupp ( 2018-06-28 12:59:53 +0100 )edit

@Lupp is right, it will take effect only for furure additions. The existing stuff needs extensive editing.

ajlittoz gravatar imageajlittoz ( 2018-06-28 13:28:20 +0100 )edit

Not sure I should be commenting here on my own thread - my first time on this forum - but I need them only to go forward from where I am. Up to this point, all quotes, having been done on the other WP, are curly anyway. So all I need is to be able to insert curly quotes as I continue typing. Is that a problem?

hirondelle gravatar imagehirondelle ( 2018-06-28 19:02:38 +0100 )edit

If it's only from now onward, follow @floris v's solution. Synce there are many variants for "curly quotes" (or typographical quotes), check that LO selects the correct ones for your locale.

ajlittoz gravatar imageajlittoz ( 2018-06-28 20:12:18 +0100 )edit

Try a few with those settings, then check that they are the same as the ones that you started with.

floris v gravatar imagefloris v ( 2018-06-28 20:44:33 +0100 )edit

Many thanks, guys. I'll check all that out tomorrow.

hirondelle gravatar imagehirondelle ( 2018-06-28 22:55:46 +0100 )edit

OK - thank you guys. Having read your comments I think my main problem was I was not understanding the process - and to be honest, I don't think LO explains it very well. But the end result is that having set the overwrite options, all I have now to do when typing is press the lower case symbol on the @ key. The first set of quotes are automatically the openers, the second set the closing ones. Not sure if it's what you're meant to do - but it works! Many thanks.

hirondelle gravatar imagehirondelle ( 2018-06-29 15:03:24 +0100 )edit
0

answered 2018-06-28 13:06:27 +0100

gabix gravatar image

Try OOoFBTools. There, Correct formatting → Hyphens, dashes, graphics etc. → Miscellanea.

edit flag offensive delete link more
0

answered 2018-07-06 15:41:56 +0100

hirondelle gravatar image

Thank you gabix - but although I'm a bit late with this, I've actually solved it - based mostly on floris v's answer. As he/she says, go to 'Tools - Autocorrect - Options for autocorrect - Localised options'. Make sure the 'Replace' options are ticked on both sets of quotes. Then click on 'Reset'. That may not be necessary, I'm not sure, but it seemed sensible as that makes sure the quotes are set to the Libre Office default ones - which you don't want! So then under both Single Quotes and Double Quotes headings, click on each in turn of the start quotes and end quotes. Each time you do that you'll be presented with a table of 'General Punctuation' - among which will be your 'curly' or 'typographical' quotes. Click on the appropriate one, then on 'Insert in each case. Then click on 'OK'. That should tell LO what quotes you want to be using. The final thing you must do, if it isn't already done, is to go to 'Tools - Autocorrect - click on 'While typing'. If you don't do that latter, your efforts will come to nothing! That has worked for me know on all three machines I use. Good luck!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-28 12:25:01 +0100

Seen: 262 times

Last updated: Jul 06 '18